Помогите срочно! Написать программу расчет площади треугольника
Ответы на вопрос
Ответ:
var a,b,alpha:integer;
s:real;
begin
Writeln('Введите две стороны и угл треугольника через пробел:');
readln(a,b,alpha);
if(alpha = 90) then
begin
s := (a*b)/2
end
else
begin
s := a*b*sin(alpha);
end;
Writeln('Площадь равна ',s);
end.
Объяснение:
Конечно, я могу помочь вам написать программу для расчета площади треугольника. Вот пример программы на языке Python:
```python # Запросить длины сторон треугольника от пользователя a = float(input("Введите длину стороны a: ")) b = float(input("Введите длину стороны b: ")) c = float(input("Введите длину стороны c: "))
# Расчет полупериметра треугольника s = (a + b + c) / 2
# Расчет площади треугольника по формуле Герона area = (s * (s - a) * (s - b) * (s - c)) ** 0.5
# Вывод площади треугольника print("Площадь треугольника равна:", area) ```
В этой программе мы сначала запрашиваем у пользователя длины сторон треугольника. Затем мы используем формулу Герона для расчета полупериметра и площади треугольника. Наконец, мы выводим площадь треугольника на экран.
Обратите внимание, что данная программа предполагает, что введенные значения сторон треугольника являются корректными и могут образовать треугольник. Если пользователь вводит некорректные значения, программа может выдать ошибку или неправильный результат. В реальных приложениях следует добавить проверки на корректность вводимых данных.
Надеюсь, эта программа поможет вам рассчитать площадь треугольника. Если у вас возникнут еще вопросы, не стесняйтесь задавать их!
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
