Вопрос задан 05.07.2018 в 22:35.
Предмет Информатика.
Спрашивает Богданчикова Карина.
Программу в Pascal ABC 1. Дано целое число А. Если значение А > 0, то необходимо увеличить его
на единицу. Напи-сать программу для решения этой задачи. Программа должна иметь дружественный интерфейс. Про-тестировать программу для A=5, A=-4, A=0. 2. Дано целое число А. Если значение А < 0, то необходимо удвоить его. Написать программу для решения этой задачи. Программа должна иметь дружественный интерфейс. Протестировать про-грамму для A=6, A=-10, A=0. 3. Дано целое число А. Если значение А <> 0, то необходимо уменьшить его на 4. Написать программу для решения этой задачи. Программа должна иметь дружественный интерфейс. Протести-ровать программу для A=2, A=-1, A=0. 4. Дано целое число А. Если значение А > 0, то необходимо увеличить его на единицу, иначе уменьшить на 1. Написать программу для решения этой задачи. Программа должна иметь друже-ственный интерфейс. Протестировать программу для A=3, A=0, A=-12. 5. Дано целое число А. Если значение А = 0, то необходимо увеличить его на 3, иначе при-своить А значение равное 0. Написать программу для решения этой задачи. Программа должна иметь дружественный интерфейс. Протестировать программу для A=0, A=-1, A=8. 6. Даны два действительных числа X и Y. Если X>Y, то вычислить произведение этих чисел, иначе их сумму. Программа должна иметь дружественный интерфейс. Протестировать программу на трёх различных тестах (X>Y, X=Y и XОтветы на вопрос
Отвечает Суфиева Фируза.
1. var a: integer;
Begin
if a > 0 then a := a + 1;
write (a);
end.
2. var a: integer;
Begin
if a < 0 then a:= a * 2;
write (a);
end.
3. var a: integer;
Begin
if a <> 0 then a:= a - 4;
write(a);
end.
4. var a: integer;
Begin
if a > 0 then a:= a + 1
else a:= a - 1;
write (a);
end.
5. var a: integer;
Begin
if a = 0 then a:= a + 3
else a:= 0;
write (a);
end.
6. var x, y: real;
if x > y then x:= x*y
else x:= x + y;
write (x);
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
