Вопрос задан 03.07.2023 в 03:25.
Предмет Информатика.
Спрашивает Картавый Саша.
Программу надо написать на c++ Программу надо написать на c++ Программу надо написать на c++
Поменять местами Дано натуральное четырехзначное число, необходимо поменять местами средние цифры. Входные данные Входные данные содержат единственное целое четырехзначное число. Выходные данные В ответ напишите четырехзначное число, которое получается из исходного обменом двух средних цифр. Примечание В этой задаче запрещено использовать символьный тип данных. Программу написать надо на c++ Программу надо написать на c++ Программу надо написать на c++Ответы на вопрос
Отвечает Елфимчев Артур.
Ответ:
#include <cmath>
#include <iostream>
using namespace std;
int main(){
int a,b,c,d;
cin >> d;
a = d%10;
b = d%100/10;
c = d/100%10;
d /= 1000;
d = d*1000+b*100+c*10+a;
cout << d;
return 0;
}
Объяснение:

Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на C++, которая меняет местами средние цифры четырёхзначного числа:
cpp#include <iostream>
int main() {
int number;
std::cout << "Введите четырехзначное число: ";
std::cin >> number;
int firstDigit = number / 1000;
int secondDigit = (number / 100) % 10;
int thirdDigit = (number / 10) % 10;
int fourthDigit = number % 10;
int newNumber = firstDigit * 1000 + thirdDigit * 100 + secondDigit * 10 + fourthDigit;
std::cout << "Число после замены: " << newNumber << std::endl;
return 0;
}
Программа запрашивает у пользователя четырёхзначное число, затем с помощью арифметических операций и операторов остатка от деления находит отдельные цифры числа. Затем она меняет местами вторую и третью цифры и выводит полученное число на экран.
Например, при вводе числа 1234 программа выведет число 1432.
Похожие вопросы
Информатика 12
Информатика 78
Информатика 94
Информатика 42
Информатика 94
Информатика 27
Информатика 41
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
