Вопрос задан 08.07.2018 в 17:55.
Предмет Информатика.
Спрашивает Федосеева Екатерина.
Напишите, пожалуйста, программы в паскалеХотябы одну :(♥♥♥ 1)По данному натуральному n вычислите
сумму 12+22+...+n2. Входные данные Вводится единственное натуральное число n, не превосходящее 100 Выходные данные Необходимо вывести вычисленную сумму. Примеры Входные данные 2 Выходные данные 5 2) Вычислите N! ("эн-факториал") – произведение всех натуральных чисел от 1 до N ( N!=1∙2∙3∙…∙ N ). Входные данные Вводится единственное число N – натуральное, не превосходит 12. Выходные данные Выведите полученное значение N! Примеры Входные данные 2 Выходные данные 2 Входные данные 3 Выходные данные 6 3) По данному натуральному числу N найдите сумму чисел 1+1/1!+1/2!+1/3!+...+1/N!. Количество действий должно быть пропорционально N. Входные данные Задано единственное число N Выходные данные Необходимо вывести результат вычисления в виде действительного числа c точностью до 5 знаков после запятой. Примеры Входные данные 1 Выходные данные 2 4) вывести таблицу умножения на 9 с помощью цикла.Ответы на вопрос
Отвечает Баранова Роксана.
1.
var n,i,s:integer;
begin
readln(n);
s:=0;
for i:=1 to n do s:=s+i*i;
writeln('s = ',s);
end.
Пример:
2
5
2.
var n,i,f:integer;
begin
readln(n);
f:=1;
for i:=1 to n do f:=f*i;
writeln(f);
end.
Пример:
3
6
3.
var n,i,f:integer; s:real;
begin
readln(n);
s:=1;
f:=1;
for i:=1 to n do
begin
f:=f*i;
s:=s+1/f;
end;
writeln(s:6:4);
end.
Пример:
3
2.6667
4.
var i:integer;
begin
for i:=1 to 9 do
writeln(9,' * ',i,' = ',9*i);
end.
Результат:
9 * 1 = 9
9 * 2 = 18
9 * 3 = 27
9 * 4 = 36
9 * 5 = 45
9 * 6 = 54
9 * 7 = 63
9 * 8 = 72
9 * 9 = 81
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
