Вопрос задан 07.04.2019 в 13:08.
Предмет Информатика.
Спрашивает Тюрин Глеб.
Написать программу, реализующую диалог с пользователем: предлагающую выбрать один из следующих
вариантов расчета: 1 - расчет тригонометрической функции 2 - расчет квадрата числа 3 - расчет корня числа По нажатии клавиши 1 пользователю предлагаются следующие варианты: s - расчет синуса c - расчет косинуса t - расчет тангенса После выбора соответствующего пункта меню пользователю предлагается ввести число, по которому необходимо провести расчет и после расчета выводится значение. В случае, если пользователь выбрал несуществующий пункт меню ему выдается сообщение об ошибке.Ответы на вопрос
Отвечает Kuntsevich Max.
var x:real;
c:char;
begin
readln(c);
readln(x);
if c='1' then begin
readln(c);
if c='s' then writeln(sin(x));
if c='c' then writeln(cos(x));
if c='t' then writeln(sin(x)/cos(x));
end else
if c='2' then
writeln(sqr(x))
else
if c='3' then
writeln(sqrt(x));
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
