
Считать массив из 10 элементов и отобрать в другой массив все числа, у которых число десятков –
ноль.Программа на C#, притом числа в массиве могут быть разного разного размера(как и 0, так и 105889900)

Ответы на вопрос

вот программа на C#, которая выполняет вашу задачу:
c#
using System;
public class Program {
public static void Main(string[] args) {
// Создайте массив из 10 элементов.
int[] array = new int[] {1, 2, 3, 4, 5, 6, 7, 8, 9, 10};
// Создайте новый массив, который будет содержать все числа из исходного массива, у которых число десятков – ноль.
int[] filteredArray = new int[array.Length];
int index = 0;
for (int i = 0; i < array.Length; i++) {
// Если число десятков в элементе исходного массива равно 0, добавьте элемент в новый массив.
if (array[i] % 10 == 0) {
filteredArray[index] = array[i];
index++;
}
}
// Выведите новый массив на консоль.
foreach (int number in filteredArray) {
Console.WriteLine(number);
}
}
}
Этот код сначала создает массив из 10 элементов. Затем он создает новый массив, который будет содержать все числа из исходного массива, у которых число десятков – ноль. Код выполняет это, просматривая элементы исходного массива и добавляя элементы, у которых число десятков равно 0, в новый массив. Наконец, код выводит новый массив на консоль.



Для выполнения этой задачи вам потребуется написать программу на C#, которая считывает массив из 10 элементов и отбирает только те числа, у которых десятки равны нулю. Вот пример такой программы:
csharpusing System;
class Program
{
static void Main()
{
int[] originalArray = new int[10];
int[] filteredArray = new int[10];
int filteredCount = 0;
// Заполните массив originalArray значениями
Console.WriteLine("Введите 10 целых чисел:");
for (int i = 0; i < 10; i++)
{
if (int.TryParse(Console.ReadLine(), out originalArray[i]))
{
// Проверяем, что десятки равны нулю
if (originalArray[i] % 100 / 10 == 0)
{
// Если условие выполняется, добавляем число в filteredArray
filteredArray[filteredCount] = originalArray[i];
filteredCount++;
}
}
else
{
Console.WriteLine("Некорректный ввод. Введите целое число.");
i--; // Повторяем попытку для того же индекса
}
}
// Выводим отфильтрованный массив
Console.WriteLine("Числа с десятками, равными 0:");
for (int i = 0; i < filteredCount; i++)
{
Console.WriteLine(filteredArray[i]);
}
}
}
В этой программе мы сначала заполняем массив originalArray
числами, затем проверяем каждое число в этом массиве. Если десятки у числа равны нулю, мы добавляем его в массив filteredArray
. В конце выводим числа, которые соответствуют условию.


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili