Вопрос задан 01.08.2023 в 23:14.
Предмет Информатика.
Спрашивает Козлова Милана.
ПОМОГИТЕ СРОЧНО, СОСТАВЛЕНИЕ ПРОГРАММЫ НА PASCAL 1. Сформировать массив из 10 произвольных чисел
и вывести его на экран. Найти сумму и произведение элементов с нечетными индексами. Подсчитать количество элементов исходного массива, значения которых превышают среднее арифметическое всех элементов массива. 2. В одномерном массиве из 14 целых чисел определить максимальный и минимальный элементы массива, напечатать их значения. Найти среднее арифметическое элементов, величина которых лежит в диапазоне от 10 до 30. Вывести массив на экран. 3. Ввести одномерный массив из восьми вещественных чисел. Распечатать массив на экране. Подсчитать количество элементов исходного массива, значения которых менее среднего арифметического всех элементов массива.. Увеличить втрое значение каждого положительного элемента, а отрицательные элементы заменить их абсолютным значением. Вывести на экран измененный массив 4. Сформировать целочисленный массив из 20 вещественных чисел. Вывести массив на экран. Определить сумму квадратов элементов с нечетными индексами. Изменить массив следующим образом: все элементы массива с нечётными номерами уменьшены вдвое, а с нечётными – увеличены в 5 раз. Вывести измененный массив на экран. 5. Сформировать массив из 15 вещественных чисел и вывести его на экран. Определить количество элементов больших его среднего арифметического значений всех нечетных элементов массива. Изменить массив следующим образом: все четные элементы массива увеличить на 7, а элементы с четными индексами уменьшить на 4. Вывести на экран измененный массив.Ответы на вопрос
Отвечает Агеев Антон.
Задание1
const nx =50;var q, n,sum,sum1,p,i:integer; sr:real;R:Array[1..10] of integer;Beginp:=1;for i:=1 to 10 do beginR[i]:= random(15)-2;sum1:= sum1 +R[i];write(R[i]:3);if i mod 2 =1 then begin sum:= sum +R[i];p:= p +R[i];end;end;writeln;sr:= sum1/10;writeln('Сумма элементов с нечетными индексами = ',sum);writeln('Произведение элементов с нечетными индексами = ',p);writeln('Среднее арифметическое всех элементов массива = ',sr);foreach q in R do beginif q > sr then n:= n + 1;end;writeln('количество элементов превышают среднее арифметическое = ',n);end.
const nx =50;var q, n,sum,sum1,p,i:integer; sr:real;R:Array[1..10] of integer;Beginp:=1;for i:=1 to 10 do beginR[i]:= random(15)-2;sum1:= sum1 +R[i];write(R[i]:3);if i mod 2 =1 then begin sum:= sum +R[i];p:= p +R[i];end;end;writeln;sr:= sum1/10;writeln('Сумма элементов с нечетными индексами = ',sum);writeln('Произведение элементов с нечетными индексами = ',p);writeln('Среднее арифметическое всех элементов массива = ',sr);foreach q in R do beginif q > sr then n:= n + 1;end;writeln('количество элементов превышают среднее арифметическое = ',n);end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, я могу помочь вам написать программу на языке Pascal для решения задач. Вот программы для каждой из указанных задач:
- Сформировать массив и вывести его, найти сумму и произведение нечетных элементов, подсчитать элементы превышающие среднее арифметическое:
pascalprogram Task1; var arr: array[1..10] of Integer; i, sumOdd, prodOdd, countAboveAvg: Integer; avg: Real; begin sumOdd := 0; prodOdd := 1; countAboveAvg := 0; // Заполняем массив случайными числами for i := 1 to 10 do arr[i] := Random(100); // Выводим массив на экран for i := 1 to 10 do Write(arr[i], ' '); // Вычисляем сумму и произведение нечетных элементов for i := 1 to 10 do begin if i mod 2 <> 0 then begin sumOdd := sumOdd + arr[i]; prodOdd := prodOdd * arr[i]; end; avg := avg + arr[i]; end; // Вычисляем среднее арифметическое avg := avg / 10; // Считаем количество элементов, превышающих среднее арифметическое for i := 1 to 10 do begin if arr[i] > avg then countAboveAvg := countAboveAvg + 1; end; writeln; writeln('Sum of odd-indexed elements:', sumOdd); writeln('Product of odd-indexed elements:', prodOdd); writeln('Number of elements above average:', countAboveAvg); end.
Вы можете скопировать этот код в среду программирования Pascal и выполнить его.
Продолжу с написанием кода для остальных задач.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
