Вопрос задан 28.03.2019 в 02:36.
Предмет Информатика.
Спрашивает Вандышева Виктория.
1. Найти те элементы массива, которые равны сумме двух своих соседей. Первый и последний элемент
имеют только по одному соседу, поэтому искомыми быть не могут. На вход программе сначало подается значение n<=100 – количество элементов в массиве. В следующей строке расположены сами элементы массива – целые числа, по модулю не превосходящие 10000. Выдайте значения искомых элементов массива в том же порядке, в каком они располагались во входных данных. 2. На вход программе подается последовательность чисел от 1 до 9, заканчивающаяся нулем. Всего будет введено не более 100000 чисел. Подсчитайте в этой последовательности количество единиц, количество двоек, количество троек и т.д. и выдайте результат. В выходных данных всегда должно быть 9 чисел. 3. Текст на английском языке запишите в массив a[1..1000] of char. Помимо английских букв в нем могут встречаться пробелы и знаки препинания. В массиве b [‘A’ ..’Z’’] of integer получите сведения о том, сколько и каких букв встречается в этом тексте. При подсчете строчные и прописные буквы не различать. На вход программе подается значение n<=1000 – количество символов в тексте. В следующей строке входных данных расположены сами символы (без разделителей). Выдайте 26 чисел – значения элементов массива b. Пример Входные данные Выходные данные 12 Hello world! 0 0 0 1 1 0 0 1 0 0 0 3 0 0 2 0 0 1 0 0 0 0 1 0 0 0 4. Подсчитайте за один проход, сколько его элементов равны максимальному элементу. На вход программе сначала подается значение n<=100 – количество элементов в массиве. В следующей строке входных данных расположены сами элементы массива – целые числа, по модулю не превосходящие 30000. Выдайте количество искомых элементов массива. 5. В массиве, заполненным произвольными целыми числами, найдите два числа, произведение которых максимально. Вложенные циклы не используйте. На вход программе сначала подается значение n<=10000 – количество элементов в массиве. В следующей строке входных данных расположены сами элементы – целые числа, по модулю непревосходящие 30000. Выдайте два искомых числа в порядке неубывания. 6. На вход программе сначала подается значение n<=100 – количество элементов в массиве. В следующей строке входных данных расположены сами элементы массива – целые числа, по модулю не превосходящие 30000. Распечатайте только те значения элементов массива, которые встречаются в нем ровно один раз. Элементы следует распечатывать в том порядке, в котором они встречаются в массиве. ____________________________________________________________ Решите любые две задачиОтветы на вопрос
Отвечает Варвашенко Лилия.
Задача 1
var
a:array [1..100] of integer;
i,n:integer;
begin
writeln('Введите n <=100');
readln(n);
writeln('Введите массив');
for i:=1 to n do
readln(a[i]);
writeln('Массив');
for i:=1 to n do
write(a[i], ' ');
writeln;
writeln('Элементы равные сумме двух соседей:');
for i:=2 to (n-1) do
if a[i]=(a[i-1]+a[i+1]) then write(a[i],' ');
writeln;
end.
задача 5
var
a:array [1..10000] of integer;
i,n, mx1, mx2:integer;
begin
writeln('Введите n <=10000');
readln(n);
writeln('Введите массив');
for i:=1 to n do
readln(a[i]);
writeln('Массив');
for i:=1 to n do
write(a[i], ' ');
writeln;
mx1:=1;
for i:=2 to n do
if a[i]>a[mx1] then mx1:=i;
if mx1=1 then mx2:=2 else mx2:=1;
for i:=1 to n do
if (a[i]>a[mx2])and(i<>mx1) then mx2:=i;
writeln('Два числа произведение которых максимально: ',a[mx2],' ',a[mx1]);
end.
var
a:array [1..100] of integer;
i,n:integer;
begin
writeln('Введите n <=100');
readln(n);
writeln('Введите массив');
for i:=1 to n do
readln(a[i]);
writeln('Массив');
for i:=1 to n do
write(a[i], ' ');
writeln;
writeln('Элементы равные сумме двух соседей:');
for i:=2 to (n-1) do
if a[i]=(a[i-1]+a[i+1]) then write(a[i],' ');
writeln;
end.
задача 5
var
a:array [1..10000] of integer;
i,n, mx1, mx2:integer;
begin
writeln('Введите n <=10000');
readln(n);
writeln('Введите массив');
for i:=1 to n do
readln(a[i]);
writeln('Массив');
for i:=1 to n do
write(a[i], ' ');
writeln;
mx1:=1;
for i:=2 to n do
if a[i]>a[mx1] then mx1:=i;
if mx1=1 then mx2:=2 else mx2:=1;
for i:=1 to n do
if (a[i]>a[mx2])and(i<>mx1) then mx2:=i;
writeln('Два числа произведение которых максимально: ',a[mx2],' ',a[mx1]);
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
