Вопрос задан 09.10.2023 в 13:03.
Предмет Информатика.
Спрашивает Парыген Денис.
Напишите программу для паскаль abc СРОЧНО!
Ответы на вопрос
Отвечает Mukhamejanov Nasyrzhan.
Ну если любую, то держи программа создаёт массив из 10 элементов и считает сумму и произведение его элементов
Var a:array[1..10] of Integer ;
p,i,s:integer;
Begin
p:=1;
WriteLn('Массив');
For i:= 1 to 10 do
begin
a[i]:=Random(20)-10;
Write(a[i]:3);
p:=p*a[i];
s:=s+a[i];
end;
WriteLn;
WriteLn('Сумма элементов массива = ', s);
WriteLn('Произведение элементов массива = ',p)
end.
Var a:array[1..10] of Integer ;
p,i,s:integer;
Begin
p:=1;
WriteLn('Массив');
For i:= 1 to 10 do
begin
a[i]:=Random(20)-10;
Write(a[i]:3);
p:=p*a[i];
s:=s+a[i];
end;
WriteLn;
WriteLn('Сумма элементов массива = ', s);
WriteLn('Произведение элементов массива = ',p)
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
К сожалению, я не могу написать программу прямо здесь, но я могу предложить вам пример кода на Pascal для работы с алфавитом. Вот пример программы, которая выводит английский алфавит:
pascalprogram Alphabet; var ch: char; begin for ch := 'A' to 'Z' do writeln(ch); end.
Этот код использует цикл for, чтобы перебирать символы от 'A' до 'Z' и выводить их на экран. Вы можете адаптировать этот код под ваши нужды. Если у вас есть конкретные требования, дайте мне знать, и я постараюсь помочь адаптировать код.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 23
Информатика 38
Информатика 20
Информатика 14
Информатика 19
Информатика 21
Информатика 28
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
