Вопрос задан 03.04.2021 в 07:56.
Предмет Информатика.
Спрашивает Шах Макс.
Pascal, помогите пожалуйста, уже достало, честное слово... Ну не моё это. 1) Напишите программу в
которой на экран выводится строка из трех случайных прописных латинских символов.Пример вывода: Паскаль: «Я сгенерировал строку: fke»2)Напишите программу, в которой с клавиатуры вводится ширина диапазона случайных чисел и выводится случайное число в диапазоне от 0 до N (где N – введенное с клавиатуры число)Пример вывода:Введите ширину диапазона случайных чисел: 150 Паскаль: «Я сгенерировал число: 48»3)Напишите программу, в которой с клавиатуры вводятся начальное и конечное значения диапазона случайных чисел и выводится случайное число в диапазоне от M до N (где M и N – введенные с клавиатуры числа)Пример вывода: Введите начало диапазона случайных чисел: 50 Введите конец диапазона случайных чисел: 150 Паскаль: «Я сгенерировал число: 89»4)Напишите программу для случайного определения победителя школьной лотереи. В лотерее участвовали билеты с тремя двузначными числами. На экран последовательно выводится три двузначных числа. Пример вывода: Первое число выигрышного билета: 54. Второе число выигрышного билета: 34. Третье число выигрышного билета: 72. Выиграл билет с комбинацией числе: 54 34 72.Ответы на вопрос
Отвечает Дашук Полина.
Program randstring;
var
a:array[1..3] of char;
i:integer;
begin
while i < 3 do begin
i+=1;
a[i]:=rand();
write(a[i]:3);
end;
end.
programm r;
var
n:integer;
begin
read(n);
write(random(n));
end.
сложный вариант
programm r;
var
a:array[1..1000]of integer;
i,m,n:integer;
begin
read(n,m);
i:=n;
while i < m do begin
i+=1;
a[i-n]:=i-n;
end;
i:=random(m-n)+1;
write(a[i])
end.
while i < 3 do begin
i+=1;
writeln(random(90)+10)
end;
var
a:array[1..3] of char;
i:integer;
begin
while i < 3 do begin
i+=1;
a[i]:=rand();
write(a[i]:3);
end;
end.
programm r;
var
n:integer;
begin
read(n);
write(random(n));
end.
сложный вариант
programm r;
var
a:array[1..1000]of integer;
i,m,n:integer;
begin
read(n,m);
i:=n;
while i < m do begin
i+=1;
a[i-n]:=i-n;
end;
i:=random(m-n)+1;
write(a[i])
end.
while i < 3 do begin
i+=1;
writeln(random(90)+10)
end;
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, я могу помочь вам с этими программами на языке Паскаль. Вот решения для каждой из задач:
- Генерация случайной строки из трех прописных латинских символов:
pascalprogram GenerateRandomString; var randomString: string; i: integer; begin randomize; for i := 1 to 3 do randomString := randomString + chr(random(26) + 65); // генерируем случайную букву от 'A' до 'Z' writeln('Паскаль: "Я сгенерировал строку: ', randomString, '"'); end.
- Генерация случайного числа в диапазоне от 0 до N:
pascalprogram GenerateRandomNumberInRange; var rangeWidth, randomNumber: integer; begin writeln('Введите ширину диапазона случайных чисел: '); readln(rangeWidth); randomize; randomNumber := random(rangeWidth + 1); // генерируем случайное число от 0 до rangeWidth writeln('Паскаль: "Я сгенерировал число: ', randomNumber, '"'); end.
- Генерация случайного числа в диапазоне от M до N:
pascalprogram GenerateRandomNumberInRange; var startRange, endRange, randomNumber: integer; begin writeln('Введите начало диапазона случайных чисел: '); readln(startRange); writeln('Введите конец диапазона случайных чисел: '); readln(endRange); randomize; randomNumber := random(endRange - startRange + 1) + startRange; // генерируем случайное число от startRange до endRange writeln('Паскаль: "Я сгенерировал число: ', randomNumber, '"'); end.
- Случайное определение победителя школьной лотереи:
pascalprogram SchoolLottery; var ticket1, ticket2, ticket3: integer; begin randomize; ticket1 := random(90) + 10; // генерируем случайное двузначное число от 10 до 99 ticket2 := random(90) + 10; ticket3 := random(90) + 10; writeln('Первое число выигрышного билета: ', ticket1); writeln('Второе число выигрышного билета: ', ticket2); writeln('Третье число выигрышного билета: ', ticket3); writeln('Выиграл билет с комбинацией чисел: ', ticket1, ' ', ticket2, ' ', ticket3); end.
Просто скопируйте соответствующий код в среду разработки Паскаля и запустите программу для каждой задачи отдельно.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
