Вопрос задан 01.10.2023 в 01:41. Предмет Информатика. Спрашивает Иванов Сергей.

2. Напишите программу для вывода на экран чисел, находящихся обе стороны (до и после) веденного

пользователем числа.3. n-ное количество учеников собрали k яблок и поделили их поровну между собой. Остальные яблоки оставили в корзинке.а) Какое количество яблок досталось каждому ученику?б) Сколько яблок в корзине?в) Напишите программу для варианта, когда пиk вводятся пользователем.4. Напишите программу для определения двух последних цифр введенного пользователем числа, большего, чем двузначное.5. Автобус за день проходит п километров. За сколько дней автобус проедет расстояние м километров? Пит вводятся пользователем. Напишите программу для решения задачи.6. Путь, пройденный муравьем, обозначен в миллиметрах. Обозначьте его в метрах, сантиметрах и миллиметрах. (например, 45 786 = 45 м 78 см 6 мм).7. Грань куба равна a. Напишите программу, вычисляющую объем куба.8. Даны числа a, b, cи d. Напишите программу для вычисления их среднеарифметического значения.9. Школьная администрация решила организовать кабинет математики для 3 классов. Поскольку занятия проходят одновременно, необходимо закупить парты для каждого кабинета отдельно. За одной партой не смогут сидеть больше двух учеников. Сколько парт надо купить, если известно количество учащихся в каждом классе? Пользователь вводит три значения - количество учеников в каждом классе.​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Гнедина Елизавета.

Ответ:

2) Вопрос не понял, но думаю правильно ответил:

var a,b,c,d :int64;

begin

readln(a);

b := a -1;//число до  

c := a +1;//число след.

writeln('Число до: ',b,' Число след.: ',c);

end.

3)

var a,b,c,d :int64;

begin

readln(a);//Кол-во учеников

readln(b);//Кол-во яблок

c := b div a;//Яблок каждому ученику

d := b - (a * c);//Яблок в корзине  

writeln('Яблок каждому: ',c,' Яблок осталось в корзине: ',d);

end.

4)

var a,b,c,d:int64;

begin

readln(a);//Число

b := a mod 10;//остаток от деления

c := a div 10;//деление без остатка

d := c mod 10;//остаток от деления

writeln('При последнее число: ',d,' Последнее число: ',b);

end.

5)

var a,b,c,d:int64;

begin

readln(a);//Автобус за день  

readln(b);//Кол-во дней

c := a * b;

writeln('Автобус проехал: ',c,' (км)');

end.

6)

var a,b,c,d:int64;

begin

readln(a);//Путь муравья

b:= a div 1000;//м

c:= (a - (b*1000)) div 10;

//см

d:= a - (b*1000+c*10);

//мм

writeln('Путь муравья: ',b, ' (м) ',c,' (см) ',d,' (мм)');

end.

7)

var a,b,c,d:int64;

begin

readln(a);//Грань куба

b := a*a*a ;

writeln('Объем куба: ',b, ' м^3');

end.

8)

var a,b,c,d,g:real;

begin

readln(a,c,d,b);//Числа

g:=(a+c+d+b) / 4 ;

writeln('Cреднее арифметическое: ', g);

end.

9)

var a,b,c,d:real;

begin

readln(a,b,c);//Учеников в кадом классе

d:= (a+b+c)/ 2;

writeln('Кол-во парт для 3 классов: ', d);

end.

Объяснение:Все программы написаны на Pascal.

Капец много задач за 5б)))

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот программы на Python для решения каждой из задач:

  1. Программа для вывода чисел до и после введенного пользователем числа:
python
num = int(input("Введите число: ")) print("Число до:", num - 1) print("Число после:", num + 1)
  1. Программа для разделения яблок между учениками:
python
n = int(input("Введите количество учеников: ")) k = int(input("Введите количество яблок: ")) apples_per_student = k // n apples_in_basket = k % n print("Яблок каждому ученику:", apples_per_student) print("Яблок в корзине:", apples_in_basket)
  1. Программа для определения двух последних цифр числа:
python
num = int(input("Введите число больше двузначного: ")) last_two_digits = num % 100 print("Две последние цифры числа:", last_two_digits)
  1. Программа для вычисления времени, за которое автобус проедет заданное расстояние:
python
distance = float(input("Введите расстояние в километрах (м): ")) speed = float(input("Введите скорость автобуса (км/ч): ")) days = distance / speed print("Автобус проедет расстояние за", days, "часов")
  1. Программа для конвертации пути муравья:
python
path_in_mm = int(input("Введите путь муравья в миллиметрах: ")) meters = path_in_mm // 1000 centimeters = (path_in_mm % 1000) // 10 millimeters = path_in_mm % 10 print(f"{path_in_mm} мм = {meters} м {centimeters} см {millimeters} мм")
  1. Программа для вычисления объема куба:
python
a = float(input("Введите длину ребра куба (a): ")) volume = a ** 3 print("Объем куба:", volume)
  1. Программа для вычисления среднеарифметического значения:
python
a = float(input("Введите значение a: ")) b = float(input("Введите значение b: ")) c = float(input("Введите значение c: ")) d = float(input("Введите значение d: ")) average = (a + b + c + d) / 4 print("Среднеарифметическое значение:", average)
  1. Программа для определения количества парт:
python
class1_students = int(input("Введите количество учеников в первом классе: ")) class2_students = int(input("Введите количество учеников во втором классе: ")) class3_students = int(input("Введите количество учеников в третьем классе: ")) total_students = class1_students + class2_students + class3_students total_desks = (total_students + 1) // 2 # Добавляем 1, чтобы учесть деление "вниз" print("Необходимо купить", total_desks, "парт")
0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос