Вопрос задан 08.06.2023 в 07:58. Предмет Информатика. Спрашивает Қамысбек Қазыбек.

ПЖ СРОЧНО :) дам 100б 2. Напишите программу для вывода на экран чисел,находящихся обе стороны (до

и после) веденного пользователем числа.3. n-ное количество учеников собрали k яблок и поделили их поровну между собой. Остальные яблоки оставили в корзинке.а) Какое количество яблок досталось каждому ученику?б) Сколько яблок в корзине?в) Напишите программу для варианта, когда пиk вводятся пользователем.4. Напишите программу для определения двух последних цифр введенного пользователем числа, большего, чем двузначное.5. Автобус за день проходит п километров. За сколько дней автобус проедет расстояние м километров? Пит вводятся пользователем. Напишите программу для решения задачи.6. Путь, пройденный муравьем, обозначен в миллиметрах. Обозначьте его в метрах, сантиметрах и миллиметрах. (например, 45 786 = 45 м 78 см 6 мм).7. Грань куба равна a. Напишите программу, вычисляющую объем куба.8. Даны числа a, b, cи d. Напишите программу для вычисления их среднеарифметического значения.9. Школьная администрация решила организовать кабинет математики для 3 классов. Поскольку занятия проходят одновременно, необходимо закупить парты для каждого кабинета отдельно. За одной партой не смогут сидеть больше двух учеников. Сколько парт надо купить, если известно количество учащихся в каждом классе? Пользователь вводит три значения - количество учеников в каждом классе.​​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Латышева Тамара.

2.

num = int(input("Введите число: "))

print("Числа до:", end=" ")

for i in range(num):

   print(i, end=" ")

print("\nЧисла после:", end=" ")

for i in range(num + 1, num + 6):

   print(i, end=" ")

3. Программа для нахождения количества яблок, которое досталось каждому ученику и сколько осталось в корзине:

n = int(input("Введите количество учеников: "))

k = int(input("Введите количество яблок: "))

apples_per_student = k // n

apples_left = k % n

print("Каждому ученику досталось", apples_per_student, "яблок")

print("Осталось в корзине", apples_left, "яблок")

Для варианта, когда n и k вводятся пользователем, можно заменить первые две строки на:

n = int(input("Введите количество учеников: "))

k = int(input("Введите количество яблок: "))

4.

num = int(input("Введите число (больше 99): "))

last_two_digits = num % 100

print("Две последние цифры:", last_two_digits)

5.

distance = float(input("Введите расстояние в км: "))

speed = float(input("Введите среднюю скорость автобуса в км/ч: "))

days = distance / (speed * 24)

print("Дней для проезда расстояния:", days)

6.

path_mm = int(input("Введите путь в миллиметрах: "))

path_m = path_mm // 1000

path_cm = (path_mm % 1000) // 10

path_mm = path_mm % 10

print("Путь в метрах:", path_m, "м")

print("Путь в сантиметрах:", path_cm, "см")

print("Путь в миллиметрах:", path_mm, "мм")

7.

a = float(input("Введите длину грани куба: "))

volume = a ** 3

print("Объем куба:", volume)

8.

a = float(input("Введите число a: "))

b = float(input("Введите число b: "))

c = float(input("Введите число c: "))

d = float(input("Введите число d: "))

average = (a + b + c + d) / 4

print("Среднее арифметическое значение a, b, c и d: ", average)

9.

# Запрос количества учеников для каждого класса

class1 = int(input("Введите количество учеников в первом классе: "))

class2 = int(input("Введите количество учеников во втором классе: "))

class3 = int(input("Введите количество учеников в третьем классе: "))

# Вычисление общего количества парт, необходимых для трех классов

desks = (class1 + class2 + class3 + 1) // 2

# Вывод количества парт, необходимых для каждого класса

print("Для первого класса нужно", (class1 + 1) // 2, "парт")

print("Для второго класса нужно", (class2 + 1) // 2, "парт")

print("Для третьего класса нужно", (class3 + 1) // 2, "парт")

print("Всего необходимо закупить", desks, "парт")

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я могу помочь с написанием программ для решения данных задач. Вот решения для каждой из них на языке программирования Python:

  1. Программа для вывода чисел до и после введенного числа:
python
number = int(input("Введите число: ")) for i in range(number-1, number+2): print(i)

3.а) Программа для распределения яблок между учениками:

python
n = int(input("Введите количество учеников: ")) k = int(input("Введите количество яблок: ")) apples_per_student = k // n print("Количество яблок на каждого ученика:", apples_per_student)

3.б) Программа для определения количества яблок в корзине:

python
n = int(input("Введите количество учеников: ")) k = int(input("Введите количество яблок: ")) apples_per_student = k // n remaining_apples = k % n print("Количество яблок в корзине:", remaining_apples)
  1. Программа для определения двух последних цифр введенного пользователем числа:
python
number = int(input("Введите число больше 99: ")) last_two_digits = number % 100 print("Две последние цифры числа:", last_two_digits)
  1. Программа для расчета количества дней, за которые автобус проедет заданное расстояние:
python
distance = int(input("Введите расстояние в километрах: ")) speed = int(input("Введите скорость автобуса в километрах в час: ")) days = distance // speed if distance % speed != 0: days += 1 print("Автобус проедет расстояние за", days, "дней")
  1. Программа для преобразования пути муравья из миллиметров в метры, сантиметры и миллиметры:
python
path_mm = int(input("Введите путь муравья в миллиметрах: ")) meters = path_mm // 1000 centimeters = (path_mm % 1000) // 10 millimeters = path_mm % 10 print("Путь муравья:", meters, "м", centimeters, "см", millimeters, "мм")
  1. Программа для вычисления объема куба:
python
a = float(input("Введите длину ребра куба: ")) volume = a ** 3 print("Объем куба:", volume)
  1. Программа для вычисления среднеарифметического значения четырех чисел:
python
a = float(input("Введите первое число: ")) b = float(input("Введите второе число: ")) c = float(input("Введите третье число: ")) d = float(input("Введите четвертое число: ")) average =
0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос