Вопрос задан 11.07.2023 в 06:35. Предмет Информатика. Спрашивает Нагурський Святослав.

Питон:В одном из своих видео Маша рассказывает о том, как она провела N дней в Петербурге и о том,

сколько денег она тратила на развлечения в каждый из этих дней. Найдите, на какой по счёту день поездки Маша потратила больше всего денег. Если дней, когда Маша потратила наибольшую сумму денег, несколько, то выведите номер первого из них. Формат входных данных Целое положительное число 1 < N < 1000 - количество дней N целых положительных чисел < 1000000 - траты в каждый из дней по порядку Формат выходных данных Номер дня. входные данные выходные данные 5 150 120 160 170 270 5 4 100 200 300 300
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Абрамов Михаил.

Ответ:

r=0

m=0

x=0

N=int(input())

for i in range(N):

   x=int(input())

   if x>m:

       r=i+1

       m=x

print(r)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения этой задачи, нужно прочитать входные данные, найти день с максимальными тратами и вывести его номер. Вот пример кода на Python:

python
def find_max_spending_day(days, expenses): max_spending = -1 max_day = -1 for day, expense in enumerate(expenses, 1): if expense > max_spending: max_spending = expense max_day = day return max_day # Ввод данных N = int(input()) # Количество дней expenses = list(map(int, input().split())) # Траты в каждый день # Находим номер дня с максимальными тратами result = find_max_spending_day(N, expenses) print(result)

Вы можете использовать данный код, чтобы найти номер дня с наибольшими тратами для любого количества дней и расходов. Просто введите входные данные в формате, указанном в задаче, и программа выведет номер дня с максимальными тратами.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос