Написать программу нахождения количества рулонов обоев, необходимых для ремонта комнаты
Ответы на вопрос
1 uses crt;
2 var d,s,p,v,rez: real;
3
4 begin
5 write ('Укажите длину рулона обоев ');
6 readln (d);
7 write ('Укажите ширину рулона обоев ');
8 readln (s);
9 write ('Укажите высоту комнаты ');
10 readln (v);
11 write ('Укажите периметр комнаты ');
12 readln (p);
13 rez:=(round((p/s)*v)/d);
14 writeln ('Для оклейки понадобятся ',rez,' рулонов обоев');
15 end.
Для написания программы нахождения количества рулонов обоев, необходимых для ремонта комнаты, вам потребуется знать размеры комнаты и размеры рулона обоев. Вот пример простой программы на Python:
python# Введите размеры комнаты
длина_комнаты = float(input("Введите длину комнаты в метрах: "))
ширина_комнаты = float(input("Введите ширину комнаты в метрах: "))
высота_стен = float(input("Введите высоту стен в метрах: "))
# Введите размеры рулона обоев
ширина_рулона = float(input("Введите ширину рулона обоев в сантиметрах: "))
длина_рулона = float(input("Введите длину рулона обоев в метрах: "))
# Вычислите площадь стен
площадь_стен = 2 * (длина_комнаты + ширина_комнаты) * высота_стен
# Вычислите площадь рулона обоев в квадратных метрах
площадь_рулона = (ширина_рулона / 100) * длина_рулона
# Вычислите количество рулонов обоев, необходимых для ремонта
количество_рулонов = площадь_стен / площадь_рулона
# Округлите количество рулонов до целого числа в большую сторону
количество_рулонов = int(количество_рулонов + 0.5)
# Выведите результат
print("Для ремонта комнаты вам понадобится", количество_рулонов, "рулонов обоев.")
Эта программа позволит вам ввести размеры комнаты и рулона обоев, а затем вычислит количество рулонов обоев, необходимых для покрытия стен комнаты. Количество рулонов округляется до целого числа в большую сторону, так как нельзя купить дробные рулоны обоев.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
