Вопрос задан 27.02.2019 в 16:10. Предмет Информатика. Спрашивает Дюков Антон.

Помогите с Пасклем! На вход программе подаются три целых числа a, b, c – длины сторон треугольника.

Вывести значение площади данного треугольника. Гарантируется, что с введёнными длинами сторон треугольник существует. Можно использовать любой способ нахождения площади треугольника.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Романова Валерия.
Var a,b,c:integer; p,s:real;
begin
readln(a,b,c);
p:=(a+b+c)/2;
s:=sqrt(p*(p-a)*(p-b)*(p-c));
writeln('s = ',s:5:2);
end.

Пример:
3 4 5
s = 6.00
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Решение задачи нахождения площади треугольника в Паскале

Для нахождения площади треугольника, заданного длинами его сторон, можно использовать формулу Герона. Формула Герона

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос