
составить программу в паскале. Дано а; если больше 7ми то умножить на 10, если меньше, то прибавить
7

Ответы на вопрос

я не помню паскаль:(
Объяснение:
вводишь число a
через if проверяешь условие
if(a>7) то a:=a*10
else if (a<7) то а:=а+7



Я могу помочь вам составить программу на Паскале, которая решает задачу, которую вы задали. Вот возможный вариант кода:
```pascal program PascalExample; var a: integer; begin writeln('Введите значение a:'); readln(a); if a > 7 then a := a * 10 else a := a + 7; writeln('Результат: ', a); end. ```
Эта программа сначала объявляет переменную `a` типа `integer`, то есть целое число. Затем программа выводит на экран сообщение `Введите значение a:` и ждет, пока пользователь введет число с клавиатуры. После этого программа проверяет условие `a > 7`, то есть, больше ли `a` семи. Если это верно, то программа умножает `a` на 10 и присваивает результат обратно `a`. Если это неверно, то программа прибавляет к `a` семь и присваивает результат обратно `a`. Наконец, программа выводит на экран сообщение `Результат: ` и значение `a`.


Похожие вопросы







Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili