Вопрос задан 27.09.2023 в 15:14. Предмет Информатика. Спрашивает Алпеев Паша.

мова Python. Число називається крутим, якщо у ньому парна кількість цифр, а також, якщо розділити

число по середині на дві частини однакової довжини, то новоутворені числа будуть Однаковими. Наприклад, числа 9595, 11, 880880 — круті, а числа 100 (непарна кількість) та 992993 ( 992 + 993) не є такими. Знайдіть кількість крутих чисел від 1 до п. Входные данные Перший рядок містить одне ціле число п(1 п = 1012). Выходные данные Виведіть кількість чисел. Заметка У першому прикладі крутими числами є11, 22, 33, 44, 55, 66, 77, 88, 99. У другому прикладі крутими числами є 11, 22, 33, 44,​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Амангелди Аяжан.

Ответ:

n=int(input())

k=0

if n>9:

   st_n=str(n)

   r=len(st_n)

   if r% 2==0:

      m=r//2

      s1=st_n[0:m]

      s2=st_n[m:r]

      if s2>=s1:

          k=int(s1)

      else:

          k=int(s1)-1

   else:

       n=10**(r-1)-1

       st_n=str(n)

       r=len(st_n)

       m=r//2

       s1=st_n[0:m]

       s2=st_n[m:r]

       k=int(s1)

print (k)

Объяснение:

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для знаходження кількості крутих чисел від 1 до заданого числа p, можна використовувати мову програмування Python. Ось програма, яка це робить:

python
def is_kaprekar(num): # Перетворення числа у строку num_str = str(num) # Перевірка на парність кількості цифр if len(num_str) % 2 != 0: return False # Розділення числа на дві половини half_len = len(num_str) // 2 left_half = num_str[:half_len] right_half = num_str[half_len:] # Перевірка, чи однакові половини return left_half == right_half def count_kaprekar_numbers(p): count = 0 for num in range(1, p + 1): if is_kaprekar(num): count += 1 return count # Зчитуємо значення p з вхідного потоку p = int(input()) result = count_kaprekar_numbers(p) # Виводимо результат print(result)

Ця програма визначає, чи число є "крутим", використовуючи функцію is_kaprekar, і потім перебирає всі числа від 1 до p, обчислюючи кількість крутих чисел. Наприклад, якщо p дорівнює 1000000000000, програма знайде кількість крутих чисел у діапазоні від 1 до 1000000000000 і виведе результат.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос