Вопрос задан 08.05.2021 в 00:06. Предмет Информатика. Спрашивает Минаев Кирилл.

Написать программу подсчёта x процентов от заданного числа. число и проценты вводятся с клавиатуры.

Ответы на вопрос

Отвечает Айткенова Когершин.

#include <iostream>
using std::cout;
using std::cin;
using std::endl;

int main()
{
   double x, percent;

   cout << "Enter the number: ";
   cin >> x;
   cout << "Enter the percentage: ";
   cin >> percent;

   cout << "\n" << percent << " percent of the " << x
      << " = " << (x / 100 * percent) << endl;

   return 0;
}


Отвечает Кавалян Левон.

Конечно, вот пример программы на языке Python, который решает данную задачу:

python
# получаем число и проценты от пользователя number = float(input("Введите число: ")) percent = float(input("Введите проценты: ")) # вычисляем процент от числа result = number * (percent / 100) # выводим результат print(f"{percent}% от {number} равно {result}")

Эта программа сначала запрашивает у пользователя число и проценты, а затем вычисляет процент от числа, используя формулу:

scss
процент от числа = (число * проценты) / 100

Наконец, программа выводит результат на экран с помощью функции print(). Результат будет выглядеть, например, так:

Введите число: 100 Введите проценты: 20 20.0% от 100.0 равно 20.0

Последние заданные вопросы в категории Информатика

Информатика 03.06.2023 05:00 2 Ким Елена.
Ответов: 1