Вопрос задан 07.09.2023 в 03:27.
Предмет Информатика.
Спрашивает Карелина Ксения.
Дано Х и N. Составить программу для Х в степени N на Паскале.
Ответы на вопрос
Отвечает Неделько Злата.
О типах x и n неизвестно ничего, но по сложившейся традиции резонно предположить, что n - целое, x - вещественное. Представленная программа написана именно в таком понимании типов переменных.
var
i,n:integer;
x,p:double;
begin
Write('Введите основание (x) и показатель степени (n): ');
Read(x,n);
if x=0 then p:=0
else begin
p:=1;
for i:=1 to Abs(n) do p:=p*x;
if n<0 then p:=1/p
end;
Writeln(x,'^',n,'=',p)
end.
Тестовые решения:
Введите основание (x) и показатель степени (n): 2 30
2^30=1073741824
Введите основание (x) и показатель степени (n): -3.35 9
-3.35^9=-53137.7624927636
Введите основание (x) и показатель степени (n): 18.3 -4
18.3^-4=8.9165251950717E-06
var
i,n:integer;
x,p:double;
begin
Write('Введите основание (x) и показатель степени (n): ');
Read(x,n);
if x=0 then p:=0
else begin
p:=1;
for i:=1 to Abs(n) do p:=p*x;
if n<0 then p:=1/p
end;
Writeln(x,'^',n,'=',p)
end.
Тестовые решения:
Введите основание (x) и показатель степени (n): 2 30
2^30=1073741824
Введите основание (x) и показатель степени (n): -3.35 9
-3.35^9=-53137.7624927636
Введите основание (x) и показатель степени (n): 18.3 -4
18.3^-4=8.9165251950717E-06
Отвечает Гнедкова Маша.
Var x, n, res, i: integer;
begin
res:=1;
readln(x);
readln(n);
for i:= 1 to n do
res:=res*x;
writeln(x, '^', n, ' = ', res);
end.
begin
res:=1;
readln(x);
readln(n);
for i:= 1 to n do
res:=res*x;
writeln(x, '^', n, ' = ', res);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на Pascal, которая возводит число X в степень N:
pascalprogram ВозведениеВСтепень; var X, N, Result: real; function Power(X: real; N: integer): real; var i: integer; begin Result := 1; for i := 1 to N do Result := Result * X; end; begin // Ввод X и N с клавиатуры write('Введите X: '); readln(X); write('Введите N: '); readln(N); // Вызов функции для вычисления степени Result := Power(X, N); // Вывод результата writeln(X, ' в степени ', N, ' равно ', Result); // Завершение программы readln; end.
В этой программе сначала вводятся значения X и N с клавиатуры. Затем вызывается функция Power, которая вычисляет X в степени N с помощью цикла. Результат выводится на экран. Вы можете запустить эту программу в своей среде разработки Pascal.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 17
Информатика 40
Информатика 27
Информатика 61
Информатика 10
Информатика 13
Информатика 42
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
