
Вопрос задан 29.07.2023 в 13:47.
Предмет Информатика.
Спрашивает Виноградов Кирилл.
В двумерном массиве числа, кратные n, заменить частными от деления на n. Написать программу на
паскале.помогите пожалуйста

Ответы на вопрос

Отвечает Гулеева Александра.
Var a:array[1..20,1..20] of integer;i,j,n:integer;beginreadln(n);for i:=1 to n dofor j:=1 to n doread(a[i,j]);
for i:=1 to n dofor j:=1 to n doif a[i,j] mod n =0 then a[i,j]:=a[i,j] div n;
for i:=1 to n do beginfor j:=1 to n dowrite(a[i,j],' ');writeln;end;end.
for i:=1 to n dofor j:=1 to n doif a[i,j] mod n =0 then a[i,j]:=a[i,j] div n;
for i:=1 to n do beginfor j:=1 to n dowrite(a[i,j],' ');writeln;end;end.



Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на языке Pascal, которая заменяет числа в двумерном массиве, кратные заданному числу n
, частными от деления на n
:
pascalprogram ReplaceMultiplesWithQuotients; const ROWS = 3; // Количество строк в массиве COLS = 3; // Количество столбцов в массиве; var arr: array[1..ROWS, 1..COLS] of integer; n, i, j: integer; procedure ReplaceMultiplesWithQuotients(n: integer); var i, j: integer; begin for i := 1 to ROWS do begin for j := 1 to COLS do begin // Проверяем, кратно ли число n if arr[i, j] mod n = 0 then arr[i, j] := arr[i, j] div n; // Заменяем на частное от деления end; end; end; begin // Инициализация двумерного массива (здесь можно ввести значения с клавиатуры) arr[1, 1] := 10; arr[1, 2] := 15; arr[1, 3] := 20; arr[2, 1] := 25; arr[2, 2] := 30; arr[2, 3] := 35; arr[3, 1] := 40; arr[3, 2] := 45; arr[3, 3] := 50; writeln('Исходный массив:'); for i := 1 to ROWS do begin for j := 1 to COLS do begin write(arr[i, j]:4); end; writeln; end; // Вводим значение n write('Введите значение n: '); readln(n); ReplaceMultiplesWithQuotients(n); writeln('Массив после замены:'); for i := 1 to ROWS do begin for j := 1 to COLS do begin write(arr[i, j]:4); end; writeln; end; end.
Вы можете изменить значения элементов массива или размеры массива ROWS
и COLS
по своему усмотрению. После запуска программы она запросит ввод значения n
, а затем выведет исходный массив и массив после замены чисел, кратных n
, на их частное от деления на n
.


Похожие вопросы
Топ вопросов за вчера в категории Информатика

Информатика 563

Информатика 404

Информатика 31

Информатика 76

Информатика 16

Информатика 41

Информатика 31
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili