Вопрос задан 18.07.2023 в 04:21.
Предмет Информатика.
Спрашивает Кулакова Марина.
20 баллов.Написать программу на паскале дано трехзначное число. определить верно ли последняя
цифра этого числа четнаяОтветы на вопрос
Отвечает Худенко Александра.
Ответ:
program Test;
var
n, t: Integer;
b: Boolean;
begin
Write ('Введите трехзначное число: ');
ReadLn (n);
if (n >= 100) and (n <= 999) then begin
if (n mod 10) mod 2 = 0 then
WriteLn ('четная')
else
WriteLn ('не четная');
end else
WriteLn (n, ' - не трехзначное');
ReadLn;
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот пример программы на языке Pascal, который определяет, является ли последняя цифра трехзначного числа четной:
pascalprogram CheckLastDigit; var number: integer; lastDigit: integer; begin writeln('Введите трехзначное число: '); readln(number); // Определяем последнюю цифру числа lastDigit := number mod 10; // Проверяем, является ли последняя цифра четной if lastDigit mod 2 = 0 then writeln('Последняя цифра числа ', number, ' является четной.') else writeln('Последняя цифра числа ', number, ' не является четной.'); readln; end.
Программа запрашивает трехзначное число у пользователя, затем определяет последнюю цифру этого числа и проверяет, является ли она четной. Результат выводится на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
