
Напишите программу на Паскале, заполнив массив с помощью генератора случайных чисел в диапазоне
[-50; 50]. Дан целочисленный двумерный массив, размерности n x m. Найти сумму и произведение элементов, кратных 4 и 7. 

Ответы на вопрос

Ответ:
const
n=5;
m=6;
var
a : array [0..n, 0..m] of integer;
sum, pr, i, j : integer;
begin
randomize;
sum:=0;
pr:=1;
for j:=0 to m-1 do begin
for i:=0 to n-1 do begin
a[i,j] := random(100) - 50;
if (a[i,j] mod 4 = 0) and (a[i,j] mod 7 = 0) then begin
sum:=sum+a[i,j];
pr:=pr*a[i,j];
end;
write(a[i, j], ' ');
end;
writeln();
end;
writeln('--------------------');
writeln('Сумма = ',sum);
writeln('Произведение = ', pr);
end.



Вот программа на Паскале, которая создает целочисленный двумерный массив размерности n x m, заполняет его случайными числами в диапазоне [-50; 50], а затем находит сумму и произведение элементов, кратных 4 и 7:
pascalprogram SumAndProductOfElements; uses Crt; // Для использования функции Randomize const n = 5; // Задайте желаемое значение n m = 5; // Задайте желаемое значение m var arr: array[1..n, 1..m] of integer; i, j, sum, product: integer; procedure FillArrayRandomly; begin for i := 1 to n do for j := 1 to m do arr[i, j] := Random(101) - 50; // Генерируем случайное число в диапазоне [-50; 50] end; begin Randomize; // Инициализация генератора случайных чисел FillArrayRandomly; // Вывод сгенерированного массива writeln('Сгенерированный массив:'); for i := 1 to n do begin for j := 1 to m do write(arr[i, j]:5); writeln; end; // Инициализация суммы и произведения sum := 0; product := 1; // Находим сумму и произведение элементов, кратных 4 и 7 for i := 1 to n do for j := 1 to m do begin if (arr[i, j] mod 4 = 0) and (arr[i, j] mod 7 = 0) then begin sum := sum + arr[i, j]; product := product * arr[i, j]; end; end; // Вывод суммы и произведения writeln('Сумма элементов, кратных 4 и 7:', sum); writeln('Произведение элементов, кратных 4 и 7:', product); readkey; // Для задержки окна консоли end.
Обратите внимание, что вы можете изменить значения n
и m
, чтобы задать желаемые размерности массива.


Похожие вопросы
Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili