Вопрос задан 14.07.2023 в 04:16. Предмет Информатика. Спрашивает Балабуркин Илья.

Срочно!! Для Python 3!! Соревнование Спортсмены соревнуются в метании ядра. N спортсменов

совершили броски ядра. Количество бросков каждого из спортсменов отличается. Вам нужно написать программу, которая определит какой из спортсменов дальше всех забросил ядро. Вводные данные: в первой строке дается число N, количество спортсменов которые участвуют в метании ядер. Затем на N строках, первым идет имя спортсмена, затем через пробел значения каждого совершённого броска данного спортсмена. Выходные данные: на одной строке через пробел, имя спортсмена который совершил максимальный бросок и значение броска. Если множество спортсменов совершили максимальный бросок, то вывести первого из них который совершил данный бросок. Ввод: 3 Askhat 23 12 45 Elnur 45 32 23 Nurbek 34 45 34 Вывод такой: Askhat 45
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Макаренко Елена.

n = int(input())

maxi = 0

output = []

for i in range(n):

   x = input().split()

   temp = max([int(i) for i in x[1:]])

   if (temp > maxi):

       output = x[:]

       maxi = temp

print(output[0], ' ', max([int(i) for i in output[1:]]))

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения этой задачи, можно использовать следующий код на Python 3:

python
def find_max_throw(throws): max_throw = max(throws) max_throw_index = throws.index(max_throw) return max_throw, max_throw_index def main(): N = int(input("Введите количество спортсменов: ")) athletes = [] for i in range(N): data = input().split() name = data[0] throws = list(map(int, data[1:])) athletes.append((name, throws)) max_throw, max_throw_index = find_max_throw(athletes[0][1]) max_throw_athlete = athletes[0][0] for i in range(1, len(athletes)): throws = athletes[i][1] current_max_throw, current_max_throw_index = find_max_throw(throws) if current_max_throw > max_throw: max_throw = current_max_throw max_throw_athlete = athletes[i][0] max_throw_index = current_max_throw_index print(max_throw_athlete, max_throw) if __name__ == "__main__": main()

Вы можете запустить программу, вводя данные, как указано в вашем примере:

Введите количество спортсменов: 3 Askhat 23 12 45 Elnur 45 32 23 Nurbek 34 45 34

Вывод:

Askhat 45

Программа найдет спортсмена с максимальным броском и выведет его имя и значение броска на одной строке через пробел. Если есть несколько спортсменов с одинаковым максимальным броском, будет выведен первый из них, который достиг такого броска.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос