Вопрос задан 25.06.2019 в 21:51.
Предмет Информатика.
Спрашивает Харченко Лиза.
PASCAL ABC.NET СРОЧНО НУЖНА ПОМОЩЬ! 8) Даны натуральное число N и вещественные числа a1, a2, …, aN.
Найти количество вещественных чисел, которые больше своих соседей, т. е. предшествующего и последующего. Входные данные Во входном потоке в первой строке записано число N (1 <= N <= 10000). Во второй строке через пробел записаны N вещественных чисел ai(-10000 <= ai <= 10000). Выходные данные В выходной поток следует записать количество вещественных чисел, которые больше своих соседей. Пример Исходные данные 9 3 -1 12 5 -17 5 2 15 -5 Результат 3 9) Даны натуральное число N и целый числа a1, a2, …, aN. Найти количество пар "соседних" чисел ai, равных между собой. Входные данные Во входном потоке в первой строке записано число N (1 <= N <= 10000). Во второй строке через пробел записаны N целых чисел ai(-10000 <= ai <= 10000). Выходные данные В выходной поток следует записать количество пар "соседних" чисел ai, равных между собой. Пример Исходные данные 9 3 -1 -1 5 -17 5 2 2 -5 Результат 2 10. Даны натуральное число N и целый числа a1, a2, …, aN. Найти количество пар "соседних" чисел ai , являющихся четными числами. Входные данные Во входном потоке в первой строке записано число N (1 <= N <= 10000). Во второй строке через пробел записаны N целых чисел ai(-10000 <= ai <= 10000). Выходные данные В выходной поток следует записать количество пар "соседних" чисел ai , являющихся четными числами. Пример Исходные данные 10 3 0 4 5 -17 5 2 14 -5 Результат 2Ответы на вопрос
Отвечает Кирилл Васильев.
8)
// PascalABC.NET 3.3
begin
var n:=ReadInteger();
var a:=ReadArrReal(n);
var k:=a.Where((x,i)->(i>0)and(i<n-1)and
(a.ElementAt(i)>a.ElementAt(i-1))and(a.ElementAt(i)>a.ElementAt(i+1))).Count;
Writeln(k);
end.
Пример:
9
3 -1 12 5 -17 5 2 15 -5
3
9)
begin
var n:=ReadInteger();
var a:=ReadArrInteger(n);
var k:=a.Where((x,i)->(i<n-1)and(a.ElementAt(i)=a.ElementAt(i+1))).Count;
Writeln(k);
end.
Пример:
9
3 -1 -1 5 -17 5 2 2 -5
2
10)
begin
var n:=ReadInteger();
var a:=ReadArrInteger(n);
var k:=a.Where((x,i)->(i<n-1)and(a.ElementAt(i) mod 2=0)and(a.ElementAt(i+1) mod 2=0)).Count;
Writeln(k);
end.
Пример:
10
3 0 4 5 -17 5 2 14 -5
2
// PascalABC.NET 3.3
begin
var n:=ReadInteger();
var a:=ReadArrReal(n);
var k:=a.Where((x,i)->(i>0)and(i<n-1)and
(a.ElementAt(i)>a.ElementAt(i-1))and(a.ElementAt(i)>a.ElementAt(i+1))).Count;
Writeln(k);
end.
Пример:
9
3 -1 12 5 -17 5 2 15 -5
3
9)
begin
var n:=ReadInteger();
var a:=ReadArrInteger(n);
var k:=a.Where((x,i)->(i<n-1)and(a.ElementAt(i)=a.ElementAt(i+1))).Count;
Writeln(k);
end.
Пример:
9
3 -1 -1 5 -17 5 2 2 -5
2
10)
begin
var n:=ReadInteger();
var a:=ReadArrInteger(n);
var k:=a.Where((x,i)->(i<n-1)and(a.ElementAt(i) mod 2=0)and(a.ElementAt(i+1) mod 2=0)).Count;
Writeln(k);
end.
Пример:
10
3 0 4 5 -17 5 2 14 -5
2
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
