Вопрос задан 13.07.2023 в 05:31. Предмет Информатика. Спрашивает Киселёва Ксения.

Язык  Python 3 Игровой кубик Есть игральный кубик с шестью гранями. На каждой грани значения

от 1 до 6. За каждый бросок кубика вы получаете очки, которые выпадают на верхней грани кубика. Все очки суммируются. Вы хотите получить N очков за минимальное количество бросков, при этом вы очень удачливы и всегда выпадает то количество очков, которое вы хотите. Напишите программу, которая вычислит минимальное количество бросков, которые вы должны совершить. Вводные данные: на первой строке число N, количество очков, которые вы хотите получить. Выходные данные: одно значение, минимальное количество бросков, которое нужно совершить.   Пример 1 Ввод: 4 Вывод: 1 Пример 2 Ввод: 7 Вывод: 2 Пример 3 Ввод: 13 Вывод: 3
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Лицова Карина.

Ответ:

n = int(input())

if n % 6 == 0:

   print(n // 6)

else:

   print(n // 6 + 1)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Ниже приведено решение на языке Python 3, которое решает задачу о минимальном количестве бросков для достижения заданного количества очков на игровом кубике:

python
import math def min_dice_rolls(target): if target <= 6: return 1 else: rolls = math.ceil(target / 6) return rolls # Чтение вводных данных target = int(input()) # Вычисление минимального количества бросков min_rolls = min_dice_rolls(target) # Вывод результата print(min_rolls)

В этом решении используется функция min_dice_rolls, которая принимает целевое количество очков и вычисляет минимальное количество бросков для достижения этого количества. Если целевое количество очков меньше или равно 6, то достаточно всего одного броска, чтобы получить нужное количество очков. В противном случае, мы делим целевое количество очков на 6 и округляем вверх, чтобы учесть случаи, когда количество очков не делится равномерно на 6. Это даст нам количество бросков, достаточное для получения целевого количества очков.

Затем мы считываем входные данные, вызываем функцию min_dice_rolls и выводим результат.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос