Вопрос задан 13.07.2023 в 17:16.
Предмет Информатика.
Спрашивает Yelanzev Andrey.
Написать программу, которая вычисляет оптимальный вес пользователя, сравнивает его с реальным и
выдает рекомендацию о необходимости поправиться или похудеть. Оптимальный вес вычисляется по формуле: рост (в сантиметрах)-100. Рекомендуемый вид экрана во время работы программы приведен ниже (данные, введенные пользователем, выделены полужирным шрифтом). Введите в одной строке через пробел рост (см) и вес (кг) затем нажмите -> 170 68 Вам надо поправиться на 2.00 кг. (Язык программирования - паскаль)Ответы на вопрос
Отвечает Гаркавенко Алексей.
program rost_ves;
var
r,v,ans:real;
begin
read(r,v);
ans:=r-100-v;
if ans=0 then
write('У Вас оптимальный вес')
else
if ans>0
then
write('Вам нужно поправится на ',ans,' кг')
else
write('Вам нужно похудеть на ',abs(ans),' кг')
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для реализации данной программы на языке программирования Pascal, следуйте следующим шагам:
- Запросите у пользователя его рост и вес.
- Вычислите оптимальный вес по формуле: оптимальный_вес = рост - 100.
- Сравните оптимальный вес с реальным и определите, необходимо ли пользователю поправиться или похудеть.
- Выведите рекомендацию.
Ниже приведен код программы на Pascal:
pascalprogram OptimalWeight; var height, weight, optimalWeight: real; begin writeln('Введите свой рост (в см) и вес (в кг) через пробел:'); readln(height, weight); optimalWeight := height - 100; writeln('Оптимальный вес для вас: ', optimalWeight:0:2, ' кг.'); if weight > optimalWeight then writeln('Вам надо похудеть на ', weight - optimalWeight:0:2, ' кг.') else if weight < optimalWeight then writeln('Вам надо поправиться на ', optimalWeight - weight:0:2, ' кг.') else writeln('Ваш вес оптимальный, вы в отличной форме!'); end.
После выполнения данного кода и ввода пользователем своего роста и веса, программа вычислит оптимальный вес, сравнит его с реальным и выдаст соответствующую рекомендацию.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 17
Информатика 40
Информатика 27
Информатика 61
Информатика 10
Информатика 13
Информатика 42
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
