Вопрос задан 18.04.2021 в 21:22. Предмет Информатика. Спрашивает Фаткулин Никита.

Помогите с Паскалем пожалуйста) Паскаль АВС) 1)Написать программу, которая вычисляет сумму первых

n членов ряда 1, 3, 5, 7,… Количество суммируемых членов ряда задается во время работы программы (используя цикл с параметром).2) Решить задачу 4 используя цикл с предусловием. 3)Решить задачу 4 используя цикл с постусловием.4 задача ниже- Написать программу вычисления стоимости покупки с учетом скидки. Скидка в 10% предоставляется, если сумма покупки больше 1000 руб. Ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделены полужирным шрифтом). Вычисление стоимости покупки с учетом скидки.Введите сумму покупки и нажмите <Enter>=1200Вам предоставляется скидка 10%Сумма покупки с учетом скидки: 1080.00 руб.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Симонов Иван.
Задача 1 Программа проверена для первых четырех элементов (=16)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я могу помочь с написанием программ на языке Pascal. Вот решения задач, которые вы описали:

  1. Цикл с параметром
pascal
program SumOfOddNumbers; var n, i, sum: integer; begin write('Enter the number of terms to sum: '); readln(n); sum := 0; for i := 1 to n do begin sum := sum + (2*i-1); end; writeln('The sum of the first ', n, ' odd numbers is: ', sum); readln; end.
  1. Цикл с предусловием
pascal
program SumOfOddNumbers; var n, i, sum: integer; begin write('Enter the number of terms to sum: '); readln(n); sum := 0; i := 1; while i <= n do begin sum := sum + (2*i-1); i := i + 1; end; writeln('The sum of the first ', n, ' odd numbers is: ', sum); readln; end.
  1. Цикл с постусловием
pascal
program SumOfOddNumbers; var n, i, sum: integer; begin write('Enter the number of terms to sum: '); readln(n); sum := 0; i := 1; repeat sum := sum + (2*i-1); i := i + 1; until i > n; writeln('The sum of the first ', n, ' odd numbers is: ', sum); readln; end.
  1. Вычисление стоимости покупки с учетом скидки
pascal
program PurchaseDiscount; var amount, discountedAmount: real; begin write('Enter the purchase amount: '); readln(amount); if amount > 1000 then begin discountedAmount := amount * 0.9; writeln('You are eligible for a 10% discount'); writeln('The discounted price is: ', discountedAmount:0:2, ' rubles'); end else begin discountedAmount := amount; writeln('Sorry, the purchase amount is not enough to be eligible for a discount'); end; readln; end.

Я надеюсь, что эти решения помогут вам лучше понять, как использовать циклы и условные операторы в языке Pascal. Если у вас есть какие-либо вопросы, не стесняйтесь задавать их мне.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос