
Вопрос задан 10.07.2018 в 16:26.
Предмет Информатика.
Спрашивает Крафт Семён.
Составьте программу, которая вычисляет оптимальный вес, сравнивает его с реальным и выдаёт
рекомендацию о необходимости поправиться или похудеть (с указанием, на сколько кг нужно поправиться или похудеть). Оптимальный вес вычисляется по формуле: рост (в см) – 100.

Ответы на вопрос

Отвечает Хомяк Александра.
Программа ниже.
Код:
var
rost, ves, opt: integer;
begin
write('Введите рост: ');
readln(rost);
opt := rost - 100;
write('Введите вес: ');
readln(ves);
if ves < opt then
writeln('Вам нужно поправиться на ', opt - ves, ' кг.');
if ves > opt then
writeln('Вам нужно похудеть на ', ves - opt, ' кг.');
if ves = opt then
writeln('Ваш вес оптимальный');
end.



Топ вопросов за вчера в категории Информатика

Информатика 47

Информатика 33

Информатика 67

Информатика 18

Информатика 25

Информатика 563

Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili