Вопрос задан 09.05.2019 в 23:13. Предмет Информатика. Спрашивает Егоров Денис.

написать программу которая вычисляет оптимальный вес пользователя сравнивая его с реальными выдаёт

рекомендации о необходимости поправиться или похудеть.по формуле рост минус 100...написать то легко но учитель сказал что б говорилось на сколько худеть или поправиться надо ...(( ну ни как не могу додуматься(( помогите (( вот сама написаная программаProgram Zadacha1;Var ves, rost, optVes:integer;Beginwrite('введите массу тела');read(ves);write('введите рост в см');read(rost);optVes:=rost-100;if ves>optVes then write('вам необходимо похудеть' );if ves<optVes then write('вам необходимо поправиться');if ves=optVes then write ('ваш вес оптимальный')End.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Чигвинцев Никита.

Program Zadacha1;
Var ves, rost, optVes:integer;
Begin
  write('введите массу тела');
  read(ves);
  write('введите рост в см');
  read(rost);
  optVes:=rost-100;
  if ves>optVes then write('вам необходимо похудеть на', abs(optVes-ves) );
  if ves<optVes then write('вам необходимо поправиться на', abs(optVes-ves) );
  if ves=optVes then write ('ваш вес оптимальный')
End.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа, которую вы написали, вычисляет оптимальный вес пользователя по формуле "рост минус 100" и дает рекомендации о том, нужно ли пользователю похудеть, поправиться или если вес уже оптимальный.

Однако, для того чтобы программа давала более точные рекомендации насколько нужно изменить вес (похудеть или поправиться), можно добавить дополнительные условия на основе разницы между текущим весом пользователя и оптимальным весом.

Вот пример того, как можно модифицировать вашу программу:

```pascal Program Zadacha1; Var ves, rost, optVes, raznica: integer;

Begin write('Введите массу тела: '); read(ves); write('Введите рост в см: '); read(rost); optVes := rost - 100; raznica := abs(ves - optVes); // находим разницу между текущим и оптимальным весом if ves > optVes then begin writeln('Вам необходимо похудеть на ', raznica, ' кг'); end else if ves < optVes then begin writeln('Вам необходимо поправиться на ', raznica, ' кг'); end else begin writeln('Ваш вес оптимальный'); end End. ```

Этот код добавляет переменную `raznica`, чтобы определить насколько отличается текущий вес от оптимального. Результат будет сообщать не только о необходимости похудеть или поправиться, но и указывать на количество килограммов, на которое это нужно сделать.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос