Вопрос задан 05.07.2023 в 16:38.
Предмет Информатика.
Спрашивает Максимов Евгений.
Написать программу поиска произведения последовательности отрицательных чисел, вводимых с
клавиатуры, предшествующих первому введенному нулю. Контрольный пример: 1,2,3,-4,5,-2,0. С++Ответы на вопрос
Отвечает Глебова Наталия.
#include <iostream>
#include <vector>
#include <algorithm>
#include <string>
#include <cstdio>
#include <math.h>
using namespace std;
int main() {
long long a, mn;
mn = 1;
cin >> a;
while (a != 0) {
mn *= a;
cin >> a;
}
cout << mn;
return 0;
}
Вроде должно работать, можешь сам протестировать)
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на C++, который выполняет задачу поиска произведения последовательности отрицательных чисел до первого введенного нуля:
cpp#include <iostream>
int main() {
int number;
int product = 1; // Инициализируем произведение единицей
std::cout << "Введите последовательность чисел. Для завершения введите 0." << std::endl;
while (true) {
std::cin >> number;
if (number == 0) {
break; // Выход из цикла при вводе нуля
}
if (number < 0) {
product *= number; // Умножаем отрицательные числа на произведение
}
}
std::cout << "Произведение отрицательных чисел: " << product << std::endl;
return 0;
}
Программа будет запрашивать ввод чисел до тех пор, пока не будет введен ноль. Если число отрицательное, оно будет умножено на текущее значение произведения. Когда будет введен ноль, программа выйдет из цикла и выведет на экран полученное произведение отрицательных чисел.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
