
Вопрос задан 05.05.2020 в 10:29.
Предмет Информатика.
Спрашивает Вишня Алёна.
Написать программу поиска чисел , лежащих в интервале от -5 до 5, в последовательности чисел,
вводимых с клавиатуры, предшествующих первому ведённому нулю. Контрольный пример 1, 10, -4 , 5, -16, 5 , 0 P.S. Программу писать на C++ , также использовать оператор for)

Ответы на вопрос

Отвечает Костромин Ярик.
Язык СИ:
#include<stdio.h>
#include<stdlib.h>
int main(){
unsigned int as=0;
long long int n=-1,*a=(long long int*)malloc(as);
while(scanf("%lld",&n)==1 && n)
if(-5<=n && n<=5){
a=(long long int*)realloc(a,++as*sizeof(n));
if(a==0)return 2;
a[as-1]=n;
}
if(!n){
for(int i=0;i<as;i++)
printf("%lld ",a[i]);
printf("\n");
}else return 1;
return 0;
}



Отвечает Масалова Светлана.
#include<iostream>
using namespace std;
int main() {
const int a = 10001;
int arr[a];
int k = 0;
for (int i = 1; i != 0; i++)
{
cin >> arr[i];
if(arr[i]!=0)
if (arr[i] >= -5 && arr[i] <= 5)
cout << arr[i] << " ";
if (arr[i] == 0)
i = 0;
}
system("pause");
return 0;
}


Топ вопросов за вчера в категории Информатика

Информатика 562

Информатика 404

Информатика 31

Информатика 76

Информатика 16

Информатика 41

Информатика 31
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili