Вопрос задан 07.07.2018 в 19:35. Предмет Информатика. Спрашивает Столмакова Влада.

Напишите программу поиска всех четырёхзначных чисел, у которых все четыре цифры различны.

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Трофимова Арина.

Var i,a,b,c,d,temp:integer;
begin
for i:=1000 to 9999 do
begin
temp:=i
a:=temp div 1000;
temp:= temp mod 1000;
b:=temp div 100;
temp:= temp mod 100;
c:=temp div 10;
d:= temp mod 10;
if (a<>b)and(a<>c)and(a<>d)and(b<>c)and(b<>d)and(c<>d) then writeln(i);
end;
end.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос