Вопрос задан 24.06.2023 в 17:48.
Предмет Информатика.
Спрашивает Нафанова Полина.
Написать программу на паскаль для нахождения площади треугольника по теореме Герона. Для нахождения
полупериметра использовать функциюОтветы на вопрос
Отвечает Соломонова Елизавета.
Ответ:
ar a,b,c, sq:real;
function polup(p:real):real
var y:real;
begin
y:=(a+b+c)/2
polup:=y;
end;
writeln('Введи длины сторон a, b и c');
readln(a,b,c);
sq:=polup(a,b,c)
writeln('Площадь этого треугольника = ', sqrt(sq*(sq-a)*(sq-b)*(sq-c)));
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот пример программы на Pascal, которая находит площадь треугольника с использованием формулы Герона и функции для вычисления полупериметра:
pascalprogram HeronTriangleArea; var a, b, c, s, area: real; function CalculateSemiPerimeter(a, b, c: real): real; begin CalculateSemiPerimeter := (a + b + c) / 2; end; begin writeln('Введите длину стороны a:'); readln(a); writeln('Введите длину стороны b:'); readln(b); writeln('Введите длину стороны c:'); readln(c); if (a > 0) and (b > 0) and (c > 0) and (a + b > c) and (a + c > b) and (b + c > a) then begin s := CalculateSemiPerimeter(a, b, c); area := sqrt(s * (s - a) * (s - b) * (s - c)); writeln('Площадь треугольника: ', area:0:2); end else writeln('Треугольник с заданными сторонами не существует.'); readln; end.
Эта программа сначала запрашивает длины сторон треугольника, затем проверяет, существует ли треугольник с такими сторонами. Если треугольник существует, она вычисляет полупериметр с использованием функции CalculateSemiPerimeter и затем вычисляет площадь треугольника по формуле Герона.
Похожие вопросы
Информатика 81
Информатика 98
Информатика 31
Информатика 22
Информатика 90
Информатика 65
Информатика 23
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
