Вопрос задан 24.06.2023 в 17:26. Предмет Информатика. Спрашивает Высоцкая Александра.

С++ Напишите программу, чтобы определить количество чисел кратных 3 но не кратных 8, от 5 до 50​

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Сидоров Тимофей.

#include <iostream>

using namespace std;

int main() {

int counter = 0;

for (int i = 5; i <= 50; i++)

 if (i % 3 == 0 and i % 8 != 0)

  counter++;

cout << counter;

return 0;

}

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот пример программы на C++, которая определяет количество чисел, которые кратны 3, но не кратны 8 в диапазоне от 5 до 50:

cpp
#include <iostream> int main() { int count = 0; for (int num = 5; num <= 50; num++) { if (num % 3 == 0 && num % 8 != 0) { count++; } } std::cout << "Количество чисел, кратных 3, но не кратных 8, от 5 до 50: " << count << std::endl; return 0; }

Эта программа начинает с числа 5 и перебирает все числа до 50. Если число делится нацело на 3 (num % 3 == 0) и не делится нацело на 8 (num % 8 != 0), то оно увеличивает счетчик. В конце программа выводит количество подходящих чисел.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос