Вопрос задан 20.06.2023 в 10:12. Предмет Информатика. Спрашивает Вахрушев Константин.

Написать на Питоне не паскаль 2) Напишите программу, которая в последовательности натуральных чисел

определяет количество чисел, кратных 6 и оканчивающихся на 8. Программа получает на вход количество чисел в последовательности, а затем сами числа. Программа должна вывести одно число: количество чисел, кратных 3 и оканчивающихся на 2. 3) Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 5. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 5. Программа должна вывести одно число — сумму чисел, кратных 5.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Рязанов Витя.

# 1

n = int(input('Кол-во чисел: '))

count = 0

for i in range(n):

   num = int(input('Введите число: '))

   if (num % 6 == 0) and (num % 10 == 8):

       count += 1

print('1) Кол-во чисел( кратных 6 и оканчивающихся на 8 ):', count, '\n')

# 2

n = int(input('Кол-во чисел: '))

count = 0

for i in range(n):

   num = int(input('Введите число: '))

   if (num % 3 == 0) and (num % 10 == 2):

       count += 1

print('2) Кол-во чисел( кратных 3 и оканчивающихся на 2 ):', count, '\n')

# 3

n = int(input('Кол-во чисел: '))

s = 0

for i in range(n):

   num = int(input('Введите число: '))

   if (num % 5 == 0):

       s += num

print('3) Сумма чисел кратных 5:', s)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот решение первой программы:

```python def count_numbers(): n = int(input("Введите количество чисел в последовательности: ")) count = 0 for i in range(n): num = int(input("Введите число: ")) if num % 6 == 0 and num % 10 == 8: count += 1 print("Количество чисел, кратных 6 и оканчивающихся на 8,:", count)

count_numbers() ```

В этой программе мы сначала получаем на вход количество чисел в последовательности. Затем в цикле просим пользователя ввести каждое число и проверяем, кратно ли оно 6 и оканчивается ли на 8. Если это условие выполняется, увеличиваем счетчик на 1. После прохождения цикла выводим количество чисел, удовлетворяющих условию.

Вот решение второй программы:

```python def sum_numbers(): n = int(input("Введите количество чисел в последовательности: ")) sum = 0

for i in range(n): num = int(input("Введите число: ")) if num % 5 == 0: sum += num print("Сумма чисел, кратных 5, составляет:", sum)

sum_numbers() ```

В этой программе также получаем на вход количество чисел в последовательности. Затем в цикле просим пользователя ввести каждое число и проверяем, кратно ли оно 5. Если это условие выполняется, добавляем это число к сумме. После прохождения цикла выводим сумму чисел, кратных 5.

0 0

Похожие вопросы

Последние заданные вопросы в категории Информатика

Задать вопрос