Вопрос задан 09.02.2021 в 20:15. Предмет Информатика. Спрашивает Мась Роман.

Паскаль срочно 90 баллов Уровень 9 класса 1.Напишите программу, которая в последовательности

натуральных чисел определяет максимальное число, кратное 4. Программа должна вывести одно число — максимальное число, кратное 4 2.Напишите программу, которая в последовательности натуральных чисел определяет кол-во чисел, кратных 4. Программа должна вывести количество чисел, кратных 4. 3.Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, оканчивающихся на 4. Программа должна вывести одно число — сумму чисел, оканчивающихся на 4
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Гурин Егор.

1.

var n,i,a,m:integer;

begin

m:=-1;

write ('Введите количество чисел в последовательности: ');

readln(n);

for i:=1 to n do

begin

write ('Введите число (больше -1): ');

readln(a);

if (a mod 4 = 0) and (a>m) then m:=a

end;

write('Максимальное число, кратное 4, равно ',m);

end.


2.

var n,i,a,k:integer;

begin

write ('Введите количество чисел в последовательности: ');

readln(n);

for i:=1 to n do

begin

write ('Введите число: ');

readln(a);

if a mod 4 = 0 then k:=k+1

end;

write('Количество чисел, кратных 4, равно ',k);

end.


3.

var n,i,a,s:integer;

begin

write ('Введите количество чисел в последовательности: ');

readln(n);

for i:=1 to n do

begin

write ('Введите число: ');

readln(a);

if a mod 10 = 4 then s:=s+a

end;

write('Сумма чисел, оканчивающихся на 4, равна ',s);

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот решение задач на языке программирования Паскаль:

  1. Определение максимального числа, кратного 4:
pascal
program MaxNumberDivisibleByFour; var number, maxNumber: integer; begin maxNumber := 0; repeat write('Введите число (для завершения введите 0): '); readln(number); if (number mod 4 = 0) and (number > maxNumber) then maxNumber := number; until number = 0; writeln('Максимальное число, кратное 4: ', maxNumber); end.
  1. Определение количества чисел, кратных 4:
pascal
program CountNumbersDivisibleByFour; var number, count: integer; begin count := 0; repeat write('Введите число (для завершения введите 0): '); readln(number); if number mod 4 = 0 then count := count + 1; until number = 0; writeln('Количество чисел, кратных 4: ', count); end.
  1. Определение суммы чисел, оканчивающихся на 4:
pascal
program SumNumbersEndingWithFour; var number, sum: integer; begin sum := 0; repeat write('Введите число (для завершения введите 0): '); readln(number); if number mod 10 = 4 then sum := sum + number; until number = 0; writeln('Сумма чисел, оканчивающихся на 4: ', sum); end.

Это решение позволяет вводить числа до тех пор, пока не будет введен ноль (для завершения ввода). Затем программа вычисляет результат в соответствии с каждой задачей и выводит его на экран.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос