Вопрос задан 23.06.2023 в 20:42.
Предмет Информатика.
Спрашивает Савлукова Светлана.
Составьте программу для вычисления площади треугольника со сторонами а в с
Ответы на вопрос
Отвечает Королькова Виктория.
var S,p,a,b,c: real;
begin
writeln('Введите a');
readln(a);
writeln('Введите b');
readln(b);
writeln('Введите c');
readln(c);
p:=(a+b+c)/2;
S:=sqrt(p*(p-a)*(p-b)*(p-c));
writeln('Площадь равна ',S);
end.
Отвечает Рыбакова Елизавета.
var a, b:integer;
S:real;
begin
writeln('Введите стороны (а и б) треугольника') ;
readln(a, b);
S:=a*b/2;
write('Площадь треугольника равна: ', S) ;
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для вычисления площади треугольника по его сторонам a, b и c можно использовать формулу полупериметра и формулу Герона. Вот пример программы на Python для этой цели:
pythonimport math
# Ввод сторон треугольника
a = float(input("Введите длину стороны a: "))
b = float(input("Введите длину стороны b: "))
c = float(input("Введите длину стороны c: "))
# Вычисление полупериметра
s = (a + b + c) / 2
# Вычисление площади по формуле Герона
area = math.sqrt(s * (s - a) * (s - b) * (s - c))
# Вывод результата
print(f"Площадь треугольника со сторонами a = {a}, b = {b} и c = {c} равна {area}")
Программа сначала запрашивает у пользователя длины сторон треугольника, затем вычисляет полупериметр и, наконец, площадь, используя формулу Герона.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 14
Информатика 2231
Информатика 86
Информатика 50
Информатика 234
Информатика 31
Информатика 31
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
