Вопрос задан 17.06.2023 в 08:19. Предмет Информатика. Спрашивает Рижий Владік.

Н.1. Составить программу, которая в последовательности целых чисел определяет кол-во элементов,

подходящих  под условие: Число двузначное, нечетное, оканчивается на 3. Сначала, пользователь вводит Кол-во чисел, затем сами числа.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Щетинина Елизавета.

Pascal:

var

 n, i, a, c: Integer;

begin

 Read(n);

 c := 0;

 for i := 1 to n do begin

   Read(a);

   if (a div 100 = 0) and (a mod 10 = 3) then

     c := c + 1;

 end;

 WriteLn(c);

end.

Python:

n = int(input())

c = 0

for i in range(0, n):

   a = int(input())

   if (a // 100 == 0) and (a % 10 == 3):

       c += 1

print(str(c))

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот пример программы на языке Python, которая решает задачу подсчета количества элементов, удовлетворяющих условию: число двузначное, нечетное и оканчивается на 3.

```python # Ввод количества чисел n = int(input("Введите количество чисел: "))

# Инициализация счетчика count = 0

# Цикл для ввода чисел и проверки условия for i in range(n): num = int(input("Введите число: ")) if num >= 10 and num <= 99 and num % 2 != 0 and num % 10 == 3: count += 1

# Вывод результата print("Количество чисел, подходящих под условие:", count) ```

Программа начинается с запроса у пользователя количества чисел, которые он собирается ввести. Затем она использует цикл `for` для ввода каждого числа и проверки, удовлетворяет ли оно условию. Если число удовлетворяет условию, счетчик `count` увеличивается на 1. В конце программа выводит количество чисел, подходящих под условие.

Пример работы программы: ``` Введите количество чисел: 5 Введите число: 23 Введите число: 45 Введите число: 33 Введите число: 12 Введите число: 73 Количество чисел, подходящих под условие: 3 ```

Пожалуйста, попробуйте запустить эту программу на своем компьютере и проверить ее работу.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос