
ДАЮ 80 БАЛЛОВ ПОМОГИТЕ ПРОШУ Составить программу на языке Паскаль для решения следующей задачи:
Дан одномерный массив. Замените все отрицательные элементы массива их квадратами, положительные элементы оставьте без изменения. Входные данные для размерности массива и значения элементов массива задайте самостоятельно. На проверку нужно прислать текст кода программы, результат работы кода в виде скриншота окна программы с отображением кода и полученного результата. Программная реализация обязательна!

Ответы на вопрос

Ответ:
Var a:array[1..10] of integer;
l,m,n :integer;
begin
for l:=1 to 10 do
a[l]:=Random(30)-10;
writeln('Массив1');
for l:=1 to 10 do
write( a[l],' ');
writeln;
for l:=1 to 10 do
if a[l] <0 then a[l]:=sqr(a[l]);
writeln('Массив2');
for l:=1 to 10 do
write( a[l],' ');
writeln;
end.



Программа на языке Паскаль для замены отрицательных элементов массива их квадратами
Для решения данной задачи на языке Паскаль можно использовать следующую программу:
```pascal program ReplaceNegativesWithSquares;
const SIZE = 5; // Размерность массива
var arr: array[1..SIZE] of Integer; // Объявление массива i: Integer; // Переменная для цикла
begin // Заполнение массива произвольными значениями (для примера) arr[1] := -3; arr[2] := 5; arr[3] := -7; arr[4] := 2; arr[5] := -1;
// Замена отрицательных элементов массива их квадратами for i := 1 to SIZE do begin if arr[i] < 0 then arr[i] := arr[i] * arr[i]; end;
// Вывод полученного массива for i := 1 to SIZE do Write(arr[i], ' ');
end. ```
Результат работы программы в виде скриншота
[](https://example.com/screenshot)
Программная реализация обязательна!


Похожие вопросы
Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili