Вопрос задан 15.06.2023 в 17:41.
Предмет Информатика.
Спрашивает Гулаков Никита.
Задание 2 (35 баллов). Составить программу на языке Паскаль для решения следующей задачи: Дан
одномерный массив. Замените все отрицательные элементы массива их квадратами, положительные элементы оставьте без изменения. Входные данные для размерности массива и значения элементов массива задайте самостоятельно. На проверку нужно прислать текст кода программы, результат работы кода в виде скриншота окна программы с отображением кода и полученного результата. Программная реализация обязательна!Ответы на вопрос
Отвечает Калашникова Карина.
Ответ:
const Sz = 100;
var
a: array [1..Sz] of integer;
N: integer;//длина массива
i, sum: integer;
begin
N := 20;
sum := 0;
for i:=1 to N do
read(a[i]); // считываем
for i:=1 to N do begin
if a[i] < 0 then
a[i] := a[i] * a[i]; // меняем на квадрат если меньше 0
end;
for i:=1 to N do
write(a[i],' '); // вывод
end.
Объяснение:
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на языке Паскаль, которая решает данную задачу:
pascalprogram ReplaceNegativeElements; const SIZE = 5; // размерность массива var arr: array[1..SIZE] of Integer; i: Integer; begin // Задаем значения элементов массива arr[1] := 5; arr[2] := -2; arr[3] := 0; arr[4] := -7; arr[5] := 3; // Выводим исходный массив writeln('Исходный массив:'); for i := 1 to SIZE do write(arr[i], ' '); writeln; // Заменяем отрицательные элементы их квадратами for i := 1 to SIZE do begin if arr[i] < 0 then arr[i] := arr[i] * arr[i]; end; // Выводим измененный массив writeln('Измененный массив:'); for i := 1 to SIZE do write(arr[i], ' '); writeln; end.
Результат работы программы:
Исходный массив: 5 -2 0 -7 3 Измененный массив: 5 4 0 49 3
Вы можете сохранить этот код в файле с расширением .pas и запустить его в среде разработки, поддерживающей язык Паскаль, чтобы увидеть результат работы программы.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
