
Задание 3 (35 баллов). Составить программу на языке Паскаль для решения следующей задачи: Дан
одномерный массив. В массиве хранятся оценки по информатике учеников 9 класса. Заполнить массив случайными числами, лежащими в диапазоне от 2 до 5 включительно. Вычислите среднюю оценку в классе по информатике. Входные данные для размерности массива задайте самостоятельно. На проверку нужно прислать текст кода программы, результат работы кода в виде скриншота окна программы с отображением кода и полученного результата. Программная реализация обязательна!

Ответы на вопрос

Ответ:
const Sz = 100;
var
a: array [1..Sz] of integer;
N: integer;//длина массива
i, sum: integer;
begin
N := 20;
sum := 0; // сумма
for i:=1 to N do
a[i] := Random(2, 5); // заполняем числами от 2 до 5
for i:=1 to N do
sum := sum + a[i];
write(sum/n); // считаем среднее
end.
Объяснение:



Я могу помочь вам с заданием по программированию на языке Паскаль. Ваша задача состоит в том, чтобы создать одномерный массив, заполнить его случайными оценками по информатике и вычислить среднюю оценку в классе. Я могу сгенерировать пример кода, который решает эту задачу, но вы должны самостоятельно проверить его работоспособность и корректность. Вот пример кода:
```pascal program GPA; const N = 20; // размер массива, можно изменить по желанию MIN = 2; // минимальная оценка MAX = 5; // максимальная оценка var grades: array[1..N] of integer; // массив оценок i: integer; // индекс для цикла sum: integer; // сумма оценок avg: real; // средняя оценка begin randomize; // инициализация генератора случайных чисел sum := 0; // обнуление суммы writeln('Оценки по информатике:'); for i := 1 to N do begin grades[i] := random(MAX - MIN + 1) + MIN; // генерация случайной оценки в диапазоне от MIN до MAX writeln(grades[i]); // вывод оценки на экран sum := sum + grades[i]; // добавление оценки к сумме end; avg := sum / N; // вычисление средней оценки writeln('Средняя оценка в классе: ', avg:0:2); // вывод средней оценки с двумя знаками после запятой end. ```
Для того, чтобы запустить этот код, вам нужно иметь среду разработки и компилятор для языка Паскаль, например, [Lazarus](https://www.youtube.com/watch?v=sv1GZnCx-PM) или [Free Pascal](http://www.schoolfreeware.com). Вы можете посмотреть видео-уроки по программированию на Паскале, например, [здесь](https://www.youtube.com/watch?v=Hw4GEwhCZpc) или [здесь](https://www.youtube.com/watch?v=sv1GZnCx-PM). Вы также можете прочитать статьи по теме, например, [здесь](https://www.daniweb.com/programming/software-development/threads/90630/pascal-average-program-question) или [здесь](https://eng.libretexts.org/Bookshelves/Computer_Science/Databases_and_Data_Structures/Book%3A_Data_Structure_and_Algorithms_%28Njoroge%29/01%3A_Algorithmic_Problem_Solving/1.03%3A_Activity_3_-_Using_pseudo-codes_and_flowcharts_to_represent_algorithms). Надеюсь, это поможет вам с заданием. Удачи! how to write a Pascal program to calculate the average grade of a class


Похожие вопросы
Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili