Вопрос задан 15.06.2023 в 18:18. Предмет Информатика. Спрашивает Закиров Арсений.

Каждый n-ый элемент На вход программе подается строка текста, содержащая символы и число nn. Из

данной строки формируется список. Напишите программу, которая разделяет список на вложенные подсписки так, что nn последовательных элементов принадлежат разным подспискам. Формат входных данных На вход программе подается строка текста, содержащая символы, отделенные символом пробела и число nn на отдельной строке. Формат выходных данных Программа должна вывести указанный вложенный список. Примечание. Графическая иллюстрация для 11 теста: ​ Тестовые данные Sample Input 1: a b c d e f g h i j k l m n 3 Sample Output 1: [['a', 'd', 'g', 'j', 'm'], ['b', 'e', 'h', 'k', 'n'], ['c', 'f', 'i', 'l']] Sample Input 2: a b c d e f g h i j k l m n 2 Sample Output 2: [['a', 'c', 'e', 'g', 'i', 'k', 'm'], ['b', 'd', 'f', 'h', 'j', 'l', 'n']] Sample Input 3: a b c d e f g h i j k l m n 1 Sample Output 3: [['a', 'b', 'c', 'd', 'e', 'f', 'g', 'h', 'i', 'j', 'k', 'l', 'm', 'n']]
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Акуневич Антон.

Ответ:

l ,n,l1,c= input().split(),int(input()),[],0

for i in l:

   l1 += [l[c::n]]

   c += 1

   if c == n:

       break

print(l1)

Объяснение:

Да все просто , я думаю то говорить не чего не нужно

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вы можете использовать следующий код на Python для решения данной задачи:

python
def split_list(lst, n): nested_lst = [[] for _ in range(n)] for i, item in enumerate(lst): nested_lst[i % n].append(item) return nested_lst input_str = input().split() n = int(input()) result = split_list(input_str, n) print(result)

Программа принимает входные данные в формате строки и числа, разделенные символом пробела. Затем используется функция split_list, которая преобразует строку в список и разделяет его на вложенные подсписки так, чтобы каждый n-ый элемент принадлежал разным подспискам. Результат выводится на экран.

Примеры использования:

css
Input: a b c d e f g h i j k l m n 3 Output: [['a', 'd', 'g', 'j', 'm'], ['b', 'e', 'h', 'k', 'n'], ['c', 'f', 'i', 'l']] Input: a b c d e f g h i j k l m n 2 Output: [['a', 'c', 'e', 'g', 'i', 'k', 'm'], ['b', 'd', 'f', 'h', 'j', 'l', 'n']] Input: a b c d e f g h i j k l m n 1 Output: [['a', 'b', 'c', 'd', 'e', 'f', 'g', 'h', 'i', 'j', 'k', 'l', 'm', 'n']]
0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос