Вопрос задан 15.06.2023 в 04:04. Предмет Информатика. Спрашивает Медведев Роман.

Составьте программу, которая проверяет, входит ли буква «P» в слово (ответ должен быть «да» или

«нет»). На языке Паскаль
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Баранов Влад.

var

   s: string;

begin

   Read(s);

   if pos('Р', s) <> 0 then

       WriteLn('да')

   else

       WriteLn('нет')

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа на языке Паскаль:

``` program CheckLetterP;

var word: string; i: integer; containsP: boolean;

begin containsP := false; write('Введите слово: '); readln(word); for i := 1 to length(word) do begin if (word[i] = 'P') or (word[i] = 'p') then begin containsP := true; break; end; end; if containsP then writeln('Да, буква "P" входит в слово.') else writeln('Нет, буква "P" не входит в слово.'); end. ```

Эта программа запрашивает у пользователя слово и затем проверяет каждую букву в слове, чтобы увидеть, содержит ли оно букву "P" (в любом регистре). Если буква "P" найдена, программа выводит "Да, буква "P" входит в слово.", в противном случае программа выводит "Нет, буква "P" не входит в слово.".

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос