Вопрос задан 16.03.2021 в 01:02.
Предмет Информатика.
Спрашивает Иванов Михаил.
Написать на С++ Составьте программу для нахождения всех автоморфных чисел вотрезке [m,n].
Автоморфным называется целое число, запись которогосовпадает с последними цифрами его квадрата. Например:5^2=256^2=3625^2=625Ответы на вопрос
        Отвечает Токтасынов Алмат.
                
    #include <iostream>
using namespace std;
int
main ()
{
int k, m, n, i, p;
cin >> m >> n;
for (i = m; i <= n; i++)
{
p = i;
k = i * i - i;
while (k % 10 == 0 && p > 0)
{
k = k / 10;
p = p / 10;
};
if (p == 0)
cout << i << " ";
};
return 0;
}
            Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
                
    Вот пример программы на C++, которая находит все автоморфные числа в заданном диапазоне [m, n]:
cpp#include <iostream>
#include <cmath>
// Функция для проверки, является ли число автоморфным
bool isAutomorphic(int num) {
    int square = num * num;
    while (num > 0) {
        if (num % 10 != square % 10) {
            return false;
        }
        num /= 10;
        square /= 10;
    }
    return true;
}
// Функция для нахождения всех автоморфных чисел в заданном диапазоне
void findAutomorphicNumbers(int m, int n) {
    if (m > n) {
        std::cout << "Неверный диапазон!\n";
        return;
    }
    std::cout << "Автоморфные числа в диапазоне [" << m << ", " << n << "]:\n";
    for (int num = m; num <= n; ++num) {
        if (isAutomorphic(num)) {
            std::cout << num << std::endl;
        }
    }
}
int main() {
    int m, n;
    std::cout << "Введите начало диапазона (m): ";
    std::cin >> m;
    std::cout << "Введите конец диапазона (n): ";
    std::cin >> n;
    findAutomorphicNumbers(m, n);
    return 0;
}
Программа запрашивает у пользователя начало и конец диапазона [m, n], а затем находит и выводит все автоморфные числа в этом диапазоне. Функция isAutomorphic используется для проверки, является ли число автоморфным.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			
Математика
 - 
			
Литература
 - 
			
Алгебра
 - 
			
Русский язык
 - 
			
Геометрия
 - 
			
Английский язык
 - 
			
Химия
 - 
			
Физика
 - 
			
Биология
 - 
			
Другие предметы
 - 
			
История
 - 
			
Обществознание
 - 
			
Окружающий мир
 - 
			
География
 - 
			
Українська мова
 - 
			
Информатика
 - 
			
Українська література
 - 
			
Қазақ тiлi
 - 
			
Экономика
 - 
			
Музыка
 - 
			
Право
 - 
			
Беларуская мова
 - 
			
Французский язык
 - 
			
Немецкий язык
 - 
			
МХК
 - 
			
ОБЖ
 - 
			
Психология
 - 
			
Физкультура и спорт
 - 
			
Астрономия
 - 
			
Кыргыз тили
 - 
			
Оʻzbek tili
 
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			