Вопрос задан 25.04.2020 в 16:09. Предмет Информатика. Спрашивает Оруджова Эльмира.

В Турбо паскале Уже нужно Составить программу для обработки массива содержащего 10 целых числе.

Определить максимальный элемент массива. Выполнение каждого логического блока программы оформить в виде отдельных процедур
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Оганян Михаил.
Uses crt;
var i,j,k,n,max:integer; a:array[1..100] of integer;
procedure rmassr;
begin
    for i:=1 to n do
    a[i]:=random(10);
end;
procedure rmassy;
begin
    for i:=1 to n do
    readln(a[i]);
end;
procedure maxe;
begin
max:=a[1];
    for i:=2 to n do begin
        if a[i] > max then max:=a[i];
    end;
    writeln('max element = ', max);
end;
procedure wmass;
begin
    for i:=1 to n do
    write(a[i],' ');
    writeln;
end;
begin
clrscr;
randomize;
write('Длина массива'); readln(n);
write('1-random; 2- в ручную '); readln(k);
if k=1 then rmassr()
else rmassy();
wmass();
maxe();
readln
end.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос