
Вопрос задан 25.04.2020 в 07:00.
Предмет Информатика.
Спрашивает Мұхамедқалиева Риза.
Дан массив из 10 чисел. Определите, сколько элементов этого массива имеют минимальное
значение.(Паскаль)

Ответы на вопрос

Отвечает Малюкович Максим.
Если одномерный массив, то:
program min;
var a:array[1..10] of integer;
i,min,k:integer;
begin
writeln('Введите элементы массива');
for i:=1 to 10 do
readln(a[i]);
min:=a{1];
for i:=1 to 10 do
if a{i]<min
then min:=a{i};
for i:=1 to 10 do
if a{i]=min
then k:=k+1;
writeln('Всего элементов с минимальным значением =',k);
end.


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili