Вопрос задан 19.01.2020 в 19:53. Предмет Информатика. Спрашивает Мирославская Алина.

написать программу на паскале: в целочисленном одномерном массиве из N(N<=50)элементов.Найти

номера элементов кратных 3.Если таких элементов нет, то сообщить об этом.Массив заполнить вручную.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Ананьина Анастасия.

Program Natasha1925;
uses crt;
const n=50;
var
 a:array[1..n] of integer;
 tri:array[1..n] of integer;
 nom,i: integer;
  begin
  writeln('*** alphaues is thinking... ***');
  writeln('***          OK             ***');
  nom:=0;
  for i:=1 to n do
  begin
    write('Введите ',i,'-e число ');
    readln(a[i]);
    if a[i] mod 3 = 0 then
      begin
        nom:=nom+1;
        tri[nom]:=i;
      end;
   end;
  if nom = 0 then
      writeln('Элементов, кратных 3, нет!: ')
    else
      begin
        writeln('Номера элементов, кратных 3: ');
        for i:=1 to nom do
          begin
            write(tri[i],' ');
          end;
      end;
   writeln();
end.

0 0
Отвечает Шкурко Вікторія.

uses crt;
var
  a:array[1..50] of integer;
  i,n,k:integer;
begin
  clrscr;

  k:=0;
  write('Введите количество элементов массива'); read(n);
  writeln('Введите массив:');
  for i:=1 to n do
    read(a[i]);
  write('Номера элементов, кратных 3:');
  for i:=1 to n do

    if (a[i] mod 3=0) then
    begin
      k:=k+1;
      write(i,' ');
    end;
  if k=0 then write('Таких элементов нет.');
end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа на паскале для поиска номеров элементов массива, кратных 3:

```pascal program FindMultiplesOfThree;

const N = 50; // максимальное количество элементов в массиве

var arr: array[1..N] of Integer; // объявление массива i, count: Integer; // переменные для циклов и счетчика

begin // заполнение массива вручную for i := 1 to N do begin Write('Введите элемент массива arr[', i, ']: '); Readln(arr[i]); end;

// поиск номеров элементов, кратных 3 count := 0; // инициализация счетчика for i := 1 to N do begin if (arr[i] mod 3 = 0) then // проверка на кратность 3 begin count := count + 1; // увеличение счетчика Write(i, ' '); // вывод номера элемента end; end;

// вывод сообщения, если кратных 3 элементов нет if (count = 0) then WriteLn('В массиве нет элементов, кратных 3.');

ReadLn; end. ```

Программа просит пользователя ввести элементы массива `arr` с помощью цикла `for`. Затем она проверяет каждый элемент на кратность 3 с помощью оператора `mod` и выводит номера элементов, кратных 3, если они есть. Если таких элементов нет, программа выводит сообщение об этом.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос