Вопрос задан 26.05.2018 в 08:50.
Предмет Информатика.
Спрашивает Мещалкина Настя.
Pascal. Составьте программу для определения принадлежности точки P с координатами (x, y) области,
которая образована первой дугой синусоиды и осью Ох.Ответы на вопрос
Отвечает Андреева Ульяна.
Если первая дуга синусоиды - синусоида при 0 <= x <= pi, то область изображена на рисунке.
Точка с координатами (x, y) принадлежит области, если 0 <= x <= pi и 0 < y < sin(x), лежит на границе, если первое выполнено, и y = 0 или y = sin(x), а иначе не лежит в области.
Код (PascalABC.NET 3.2):
begin
var x, y: real;
readln(x, y);
if (0 <= x) and (x <= pi) then
if (0 < y) and (y < sin(x)) then
writeln('Внутри области')
else if (0 = y) or (y = sin(x)) then
writeln('На границе')
else
writeln('Не принадлежит')
else
writeln('Не принадлежит')
end.

Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
