Вопрос задан 23.05.2018 в 21:11.
Предмет Информатика.
Спрашивает Попова Лиля.
Паскаль, срочно Напишите программу, которая определяет правильность записи целого числа в
восьмеричной системе счисления. Формат входных данных На вход программы поступает символьная строка. Формат выходных данных Программа должна вывести ответ 'YES', если строка представляет собой правильную запись целого числа в восьмеричной системе счисления, и 'NO', если запись ошибочна. Примеры входные данные выходные данные 12345 YESОтветы на вопрос
Отвечает Иринка Иринка.
// PascalABC.NET 3.2, сборка 1383 от 09.02.2017
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString;
if s.MatchValue('[0-7]*')=s then Writeln('YES')
else Writeln('NO')
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
