Помогите написать программу в паскале. В заданном массиве найти количество чётных чисел. Вывести
исходный массив и результат.Ответы на вопрос
Program prog;
uses crt;
var a: array [0..999] of integer;
i, k, n: integer;
begin
clrscr;
write('Размер массива n = ');
readln(n);
writeln;
for i:=1 to n do
begin
write('a[',i,'] = ');
readln (a[i]);
end;
for i:=1 to n do
if a[i] mod 2 = 0 then k:=k+1;
writeln;
writeln('Количество четных чисел k = ', k);
end.
Вариант с рандомными элементами:
Program prog;
uses crt;
var a: array [0..999] of integer;
i, k, n: integer;
begin
clrscr;
randomize;
write('Размер массива n = ');
readln(n);
writeln;
for i:=1 to n do
begin
a[i]:=random(100)-50;
writeln('a[',i,'] = ',a[i]);
end;
for i:=1 to n do
if a[i] mod 2 = 0 then k:=k+1;
writeln;
writeln('Количество четных чисел k =' , k);
end.
Конечно, вот пример программы на Pascal, которая находит количество чётных чисел в заданном массиве:
```pascal program CountEvenNumbers;
const MAX_SIZE = 100; // Максимальный размер массива
type IntArray = array[1..MAX_SIZE] of Integer;
var arr: IntArray; n, i, evenCount: Integer;
procedure InputArray(var arr: IntArray; n: Integer); var i: Integer; begin writeln('Введите элементы массива:'); for i := 1 to n do begin write('arr[', i, ']: '); readln(arr[i]); end; end;
procedure CountEven(arr: IntArray; n: Integer; var evenCount: Integer); var i: Integer; begin evenCount := 0; for i := 1 to n do begin if (arr[i] mod 2) = 0 then // Проверяем чётность числа evenCount := evenCount + 1; end; end;
procedure OutputArray(arr: IntArray; n, evenCount: Integer); var i: Integer; begin writeln('Исходный массив:'); for i := 1 to n do write(arr[i], ' '); writeln; writeln('Количество чётных чисел в массиве: ', evenCount); end;
begin writeln('Введите количество элементов в массиве (не более ', MAX_SIZE, '): '); readln(n);
if (n > 0) and (n <= MAX_SIZE) then begin InputArray(arr, n); CountEven(arr, n, evenCount); OutputArray(arr, n, evenCount); end else writeln('Ошибка: некорректный размер массива.'); end. ```
Эта программа запрашивает у пользователя количество элементов в массиве, затем заполняет массив введенными числами и подсчитывает количество чётных чисел. Результатом будет вывод исходного массива и количество чётных чисел в нём.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
